Superdesk serve over HTTPS
  • Hello!

    I have managed to set up a superdesk instance (not development) using the instructions from here:

    It seems this doc may be slightly outdated since I was able to use this command and it automates the whole process including publisher. 

    The current issue I am having is that I cannot access the site after I have deployed an SSL cert (I can access it via the public IP). The error in console is a mixed content error. I can, however, access the contentapi as this seems to accept https. 

    I'd prefer not to access via the IP. Any insights into how I can serve SuperDesk over https would be greatly appreciated!
  • 2 Comments sorted by
  • I have had similar challenges with mixed content .. and also with CORS, when you reverse proxy on SSL.  

    Wasted a whole ton of time trying so many different things before I realised it is a total waste of time trying to get SSL to work from a reverse proxy because non-encrypted URLs are embedded liberally in javascript files that get loaded at the front-end

    The required (or missing) information is how do we get SSL in the back-end, because that's the solution.  Also, to get the non-encrypted URLs embedded in javascript to do so conditionally, depending on whether SSL is enabled or not

    The install script provides for using SSL URLs, but there is no information on where one might insert SSL parameters that could be used to ensure that using the encrypted URLs in the back-end  (https, wss) will actually work.

  • Yep. I am stomped here too. "CORS request did not succeed" and unable to get Publisher Settings to open on Superdesk. Any pointers appreciated.