Airtime, can't see Listener Stats / Timeout
  • Vote Up0Vote Down RubensRubens
    Posts: 4Member
    Hi dear community, I'm operating my webradio for many years now without problems and since few days, I can't see the listeners stats on the backend and can't figure out what is the cause of the problem.
    All the other pages are working fine. I never had this problem before, it's like it appeared by magic (maybe after having launched an updated with php maybe, but I was already in 7.1 before and no problems).

    image

     I have been looking everywhere without succes :
    - php modules
    - zend version compatibility
    - files permissions
    - apache / php / nginx config
    - etc/hosts removing ip6 addresses
    - going to http2

    I'm using  Ubuntu 14.04.5 LTS / php7.1 / nginx / airtime 2.5.1 / ubuntu  

    Here are more logs, I've also attached my configuration in this post.

    Apache Error Logs

    2018/07/31 06:02:00 [error] 14010#14010: *266 upstream prematurely closed connection while reading response header from upstream, client: x.x.x.x, server: onair.MyRadio.org, request: "GET / HTTP/1.1", upstream: "https://xxx.xxx.xxx.xxx:8443/", host: "onair.MyRadio.org"
    2018/07/31 06:02:36 [error] 14010#14010: *266 upstream prematurely closed connection while reading response header from upstream, client: x.x.x.x, server: onair.MyRadio.org, request: "GET /Schedule/get-current-playlist/format/json?_=1533016939771 HTTP/1.1", upstream: "https://xxx.xxx.xxx.xxx:8443/Schedule/get-current-playlist/format/json?_=1533016939771", host: "onair.MyRadio.org", referrer: "https://onair.MyRadio.org/listenerstat"
    2018/07/31 06:02:36 [error] 14009#14009: *275 upstream prematurely closed connection while reading response header from upstream, client: x.x.x.x, server: onair.MyRadio.org, request: "GET /Library HTTP/1.1", upstream: "https://xxx.xxx.xxx.xxx:8443/Library", host: "onair.MyRadio.org", referrer: "https://onair.MyRadio.org/listenerstat"
    2018/07/31 06:02:36 [error] 14009#14009: *276 upstream prematurely closed connection while reading response header from upstream, client: x.x.x.x, server: onair.MyRadio.org, request: "GET /Listenerstat/get-data?_=1533016934613 HTTP/1.1", upstream: "https://xxx.xxx.xxx.xxx:8443/Listenerstat/get-data?_=1533016934613", host: "onair.MyRadio.org", referrer: "https://onair.MyRadio.org/listenerstat"
    2018/07/31 06:02:38 [error] 14009#14009: *275 connect() failed (111: Connection refused) while connecting to upstream, client: x.x.x.x, server: onair.MyRadio.org, request: "GET /Library HTTP/1.1", upstream: "https://xxx.xxx.xxx.xxx:8443/Library", host: "onair.MyRadio.org"


    Zend error log : /var/log/airtime/zendphp.log

    2018-07-31T08:22:30+00:00 INFO (6): [ListenerstatController.php : indexAction() : line 51] - Array
    (
        [0] => Array
            (
                [keyname] => 3s_mp3_listener_stat_error
                [value] => OK
                [type] => string
            )

        [1] => Array
            (
                [keyname] => 3s_listener_stat_error
                [value] => OK
                [type] => string
            )

        [2] => Array
            (
                [keyname] => 3sHQ_listener_stat_error
                [value] => OK
                [type] => string
            )

    )

    airtime-check-system :

    AIRTIME_SERVER_RESPONDING      = OK
    KERNEL_VERSION                 = 3.13.0-101-generic
    MACHINE_ARCHITECTURE           = x86_64
    TOTAL_MEMORY_MBYTES            = 1918696
    TOTAL_SWAP_MBYTES              = 4095996
    AIRTIME_VERSION                = 2.5.1
    OS                             = Ubuntu 14.04.5 LTS x86_64
    CPU                            = Intel Xeon E312xx (Sandy Bridge)
    WEB_SERVER                     = Apache/2.4.20 (Ubuntu) mod_fastcgi/mod_fastcgi-SNAP-0910052141 mod_fcgid/2.3.9 OpenSSL/1.0.2k PHP/7.1.20-1+ubuntu14.04.1+deb.sury.org+1
    PLAYOUT_ENGINE_PROCESS_ID      = 2285
    PLAYOUT_ENGINE_RUNNING_SECONDS = 695
    PLAYOUT_ENGINE_MEM_PERC        = 1.0%
    PLAYOUT_ENGINE_CPU_PERC        = 0.0%
    LIQUIDSOAP_PROCESS_ID          = 3402
    LIQUIDSOAP_RUNNING_SECONDS     = 670
    LIQUIDSOAP_MEM_PERC            = 2.4%
    LIQUIDSOAP_CPU_PERC            = 10.4%
    MEDIA_MONITOR_PROCESS_ID       = 2274
    MEDIA_MONITOR_RUNNING_SECONDS  = 695
    MEDIA_MONITOR_MEM_PERC         = 1.5%
    MEDIA_MONITOR_CPU_PERC         = 0.0%
    -- Your installation of Airtime looks OK!

    Thanks in advance for any help ! BLESSINGS
    Post edited by Rubens at 2018-07-31 05:52:26