Installation Problems
  • I am trying to set up Newscoop on Ubuntu 18.04 LTS.
    Downloaded the files, followed instructions, php and mysql are later than required so it should work and does until I try to start a news file
    -----------------------------------------------------

    RuntimeException: PHP Warning:
    count(): Parameter must be an array or an object that implements
    Countable in
    /var/www/newscoop/vendor/symfony/monolog-bundle/Symfony/Bundle/MonologBundle/DependencyInjection/Configuration.php
    on line 459

    PHP Fatal error: Uncaught
    Symfony\Component\DependencyInjection\Exception\InvalidArgumentException:
    The service definition "kernel.debug" does not exist. in
    /var/www/newscoop/vendor/symfony/symfony/src/Symfony/Component/DependencyInjection/ContainerBuilder.php:866

    Stack trace:

    ---------------------------------------------------
    maybe someone can help. i am floundering here

    regards

    Robert
  • 1 Comment sorted by
  • Vote Up0Vote Down Said RSaid R
    Posts: 18Member
    Hello Robert,

    Newscoop is incompatible (without serious tweeking) with more recent versions of Debian and Ubantu - if you install it on Ubantu 14.04 or Debian 7 and use the console command (php application/console newscoop:install --fix --database_name newscoop --database_user root --database_password password), it will work.