Webpack:build error on fresh Ubuntu 16.04
  • I've been trying to install superdesk using the latest version of the script @ https://github.com/superdesk/fireq/blob/files/superdesk/install .

    Everything runs fine until webpack:build, where I get the following errors:

    ERROR in ./~/superdesk-core/scripts/index.js
    Module not found: Error: Cannot resolve module 'superdesk-ui-framework/dist/superdesk-ui-framework.min.css' in /opt/superdesk/client/node_modules/superdesk-core/scripts
     @ ./~/superdesk-core/scripts/index.js 5:0-69

    ERROR in ./~/superdesk-core/scripts/vendor.js
    Module not found: Error: Cannot resolve module 'superdesk-ui-framework/dist/superdesk-ui-framework' in /opt/superdesk/client/node_modules/superdesk-core/scripts
     @ ./~/superdesk-core/scripts/vendor.js 45:0-61
    Warning: Task "webpack:build" failed. Use --force to continue.


    The files that its looking for don't even seem to exist, so maybe a step is actually failing before? The only other warning I can find in the output is:
    npm WARN optional SKIPPING OPTIONAL DEPENDENCY: fsevents@^1.0.0 (node_modules/chokidar/node_modules/fsevents):
    npm WARN notsup SKIPPING OPTIONAL DEPENDENCY: Unsupported platform for fsevents@1.1.2: wanted {"os":"darwin","arch":"any"} (current: {"os":"linux","arch":"x64"})
    npm WARN client No description
    npm WARN client No repository field.
    npm WARN client No license field.


    Anyone has solved this before? I tried installing it on Debian 9 before and it failed with the same error (actually, the script failed a few times before but everything else was fixable).
    Post edited by Pablo Ramos at 2017-10-11 14:45:00