*SOLVED (?)* Unreliable Hardware Audio Output
  • Hello,

    Freshman / noob to Airtime and this forum, I installed Ubuntu Server 14.04 and Airtime yesterday. Instructions on your website are quite clear and installation was seemingly successful.

    Our intended use is for Airtime to automate shows on live FM transmission - at the moment we're not really interested in streaming.

    However, I find sound output through onboard soundcard ...challenging. The panel will show *On Air* and populate 'currently playing' with the correct song, and sometimes sound is coming through. But most of the time I get silence. And strangely, while getting silence I can run

    airtime-test-soundcard

    and hear the test tone.

    Also,
    speaker-test
    works.

    Our server has one on-board soundcard:
    aplay -l
    **** List of PLAYBACK Hardware Devices ****
    card 0: Intel [HDA Intel], device 0: STAC9200 Analog [STAC9200 Analog]
      Subdevices: 0/1
      Subdevice #0: subdevice #0
    Here's a recap of things I tried:
    1. sudo apt-get purge pulseaudio
    2. sudo apt-get install alsa-base alsa-tools alsamixer alsautils
    3. fooling around with settings in alsamixer (what is 'Auto-mute mode'?)

    Running

    sudo airtime-check-system

    returns "-- Your installation of Airtime looks OK!"

    I also did

    sudo lsof /dev/snd/*
    COMMAND    PID     USER   FD   TYPE DEVICE SIZE/OFF NODE NAME
    timidity  1643 timidity    6u   CHR  116,1      0t0  453 /dev/snd/seq
    airtime-l 1749     pypo  mem    CHR  116,3           469 /dev/snd/pcmC0D0p
    airtime-l 1749     pypo   27r   CHR 116,33      0t0  452 /dev/snd/timer
    airtime-l 1749     pypo   28u   CHR  116,3      0t0  469 /dev/snd/pcmC0D0p
    airtime-l 1749     pypo   29u   CHR  116,2      0t0  468 /dev/snd/controlC0

    And then killed timidity, to no avail.

    I am testing and trying, filling some shows completely, some almost, deleting while playing - maybe that's causing hiccups?

    Finally,
    sudo invoke-rc.d airtime-playout restart
    sudo invoke-rc.d airtime-liquidsoap restart
    sudo invoke-rc.d rabbitmq-server restart
    while the silent show is playing does nothing. Not even reboot does, but it brings up the next the show with sound.

    I'm out of ideas, hope the forum can help!

    Post edited by Daglig leder at 2017-06-25 14:45:47
  • 5 Comments sorted by
  • Easiest route is...... capture icecast's output.
    Resurrected: 16 May 2017.
  • @John's advice to capture the icecast stream, well... I'm getting "Can
    not connect to the streaming server 401, Authentication Required
    (HTTP/1.0)". I guess that problem calls for a separate post.

    Anyway, I tried reinstalling both the server and (obviously) Airtime. Installing seems to be smooth, no errors given.

    First thing to notice is that airtime installs pulseaudio on my system. Makes me wonder about the "sudo apt-get purge pulseaudio"-advice given at https://sourcefabric.booktype.pro/airtime-25-for-broadcasters/preparing-the-server/... I decided to leave it for a while for testing purposes.

    Since 'sudo lsof /dev/snd/*' now returns:
    COMMAND     PID     USER   FD   TYPE DEVICE SIZE/OFF NODE NAME
    timidity  12153 timidity    6u   CHR  116,1      0t0  421 /dev/snd/seq
    pulseaudi 18805     pypo  mem    CHR  116,3           438 /dev/snd/pcmC0D0p
    pulseaudi 18805     pypo   16u   CHR  116,2      0t0  437 /dev/snd/controlC0
    pulseaudi 18805     pypo   21u   CHR  116,2      0t0  437 /dev/snd/controlC0
    pulseaudi 18805     pypo   22u   CHR  116,3      0t0  438 /dev/snd/pcmC0D0p
    pulseaudi 18805     pypo   23u   CHR  116,2      0t0  437 /dev/snd/controlC0
    pulseaudi 18805     pypo   28u   CHR  116,2      0t0  437 /dev/snd/controlC0
    I'm telling Airtime to use pulseaudio for physical output. Testing with 'speaker-test' returns silence, presumably expected since it's supposed to use ALSA. However, 'airtime-test-soundcard' also returns silence, which is unexpected.

    Then I set Airtime to play three shows, the first 1940-1945, the second 1945-1955 and the third 2000-2010. The first
    show plays with sound, the second is silent and the third got sound - however it turns out each time it went silent, an .ogg file is in the playlist. FLAC and mp3 plays fine.

    So closing this thread for now and starting to investigate why Airtime won't play .ogg
  • If you can hear the icecast, then you can capture it, eg port 8000. Are you sure that you are not trying to capture the Icecast Admin port, by mistake eg 8001?
    Resurrected: 16 May 2017.
  • OK, I see I was a little bit unclear. That 401 error was from the System->Streams control panel - I wasn't streaming anything, just playing through the server's sound card. So there was no stream I could try to capture ;-)

    It turned out I missed forwarding port 8000 to my server - after doing so streaming works like a charm.

    The problem is that Airtime's physical output goes silent when encountering ogg files. Enable stream type ogg or opus and EVERYTHING goes silent, streams and physical. It's a pity, but as long as I stick to mp3 and FLAC files it all works.
  • The default setup uses the same wrapper.
    Try one at a time. EG Ogg OR Opus OR AAC
    I can't get Opus working here and never ever could BTW. I will ask the boss if he has.

    We CAN get AAC OGG and MP3 working concurrently - and it is doing so right now on 2 of our stations.

    Post edited by John Chewter at 2017-06-26 19:58:14
    Resurrected: 16 May 2017.