× Warning! This forum is in archival status. New contributions may not work.
Liveblog: Stuck (again) at prepopulate
  • Using local instructions here:

    https://github.com/liveblog/liveblog

    (although I'm installing on a remote AWS instance)

    Ubuntu Linux 16.04

    Can't get past here: python3 manage.py app:initialize_data;

    Port 9200 is open but that's where it gets stuck. Something to do with elasticsearch. Please help!

    Error snippet:

    (env) paul@signal:/opt/liveblog-master/server$ python3 manage.py app:initialize_data;
    INFO:flask.ext.cors:Configuring CORS with resources: {'/*': {'vary_header': True, 'supports_credentials': False, 'origins': ['.*'], 'methods': 'DELETE, GET, HEAD, OPTIONS, PATCH, POST, PUT', 'allow_headers': ['.*'], 'automatic_options': True, 'send_wildcard': False, 'intercept_exceptions': True, 'resources': '/*'}}
    INFO:flask.ext.cors:Configuring CORS with resources: {'/*': {'vary_header': True, 'supports_credentials': False, 'origins': ['.*'], 'methods': 'DELETE, GET, HEAD, OPTIONS, PATCH, POST, PUT', 'allow_headers': ['.*'], 'automatic_options': True, 'send_wildcard': False, 'intercept_exceptions': True, 'resources': '/*'}}
    INFO:flask.ext.cors:Configuring CORS with resources: {'/*': {'vary_header': True, 'supports_credentials': False, 'origins': ['.*'], 'methods': 'DELETE, GET, HEAD, OPTIONS, PATCH, POST, PUT', 'allow_headers': ['.*'], 'automatic_options': True, 'send_wildcard': False, 'intercept_exceptions': True, 'resources': '/*'}}
    INFO:flask.ext.cors:Configuring CORS with resources: {'/*': {'vary_header': True, 'supports_credentials': False, 'origins': ['.*'], 'methods': 'DELETE, GET, HEAD, OPTIONS, PATCH, POST, PUT', 'allow_headers': ['.*'], 'automatic_options': True, 'send_wildcard': False, 'intercept_exceptions': True, 'resources': '/*'}}
    INFO:flask.ext.cors:Configuring CORS with resources: {'/*': {'vary_header': True, 'supports_credentials': False, 'origins': ['.*'], 'methods': 'DELETE, GET, HEAD, OPTIONS, PATCH, POST, PUT', 'allow_headers': ['.*'], 'automatic_options': True, 'send_wildcard': False, 'intercept_exceptions': True, 'resources': '/*'}}
    INFO:superdesk.websockets_comms:Connecting to broker redis://localhost:6379
    INFO:superdesk.websockets_comms:Connected to broker redis://localhost:6379
    INFO:ldap3:ldap3 library initialized - logging emitted with loglevel set to DEBUG - available detail levels are: OFF, ERROR, BASIC, PROTOCOL, NETWORK, EXTENDED
    INFO:superdesk:got lock task=elastic host=hostid:signal pid:767
    WARNING:elasticsearch:HEAD http://localhost:9200/liveblog [status:N/A request:0.000s]
    Traceback (most recent call last):
      File "/opt/liveblog-master/server/env/lib/python3.5/site-packages/urllib3/connection.py", line 141, in _new_conn
        (self.host, self.port), self.timeout, **extra_kw)
      File "/opt/liveblog-master/server/env/lib/python3.5/site-packages/urllib3/util/connection.py", line 83, in create_connection
        raise err
      File "/opt/liveblog-master/server/env/lib/python3.5/site-packages/urllib3/util/connection.py", line 73, in create_connection
        sock.connect(sa)
    ConnectionRefusedError: [Errno 111] Connection refused

    Post edited by Paul Kelly at 2017-03-29 15:42:20