× Warning! This forum is in archival status. New contributions may not work.
Problem with plugins installation on newscoop 4.4.7
  • Can somebody help?
    That is the result when I try to install an plugin

    Problem 1
        - The requested package phpspec/prophecy (locked at 1.4.x-dev) exists as phpspec/prophecy[1.1.2, 1.4.0, dev-master, 1.6.x-dev, v1.0.0, v1.0.0-BETA1, v1.0.0-BETA2, v1.0.1, v1.0.2, v1.0.3, v1.0.4, v1.1.0, v1.1.1, v1.2.0, v1.2.1, v1.3.0, v1.3.1, v1.4.1, v1.5.0, v1.6.0, v1.6.1] but these are rejected by your constraint.
      Problem 2
        - The requested package sebastian/comparator (locked at 1.1.x-dev) exists as sebastian/comparator[1.0.0, 1.0.1, 1.1.0, 1.1.1, 1.1.2, 1.2.0, dev-master, 1.2.x-dev] but these are rejected by your constraint.
      Problem 3
        - The requested package sebastian/diff (locked at 1.3.x-dev) exists as sebastian/diff[1.0.0, 1.1.0, 1.2.0, 1.3.0, 1.4.0, 1.4.1, dev-master, 1.4.x-dev] but these are rejected by your constraint.
      Problem 4
        - The requested package sebastian/exporter (locked at 1.2.x-dev) exists as sebastian/exporter[1.0.0, 1.0.1, 1.0.2, 1.1.0, 1.2.0, 1.2.1, 1.2.2, dev-factory, dev-master, 1.3.x-dev] but these are rejected by your constraint.
      Problem 5
        - Installation request for phpunit/phpunit (locked at 4.8.x-dev, required as ~4.0) -> satisfiable by phpunit/phpunit[4.8.x-dev].
        - phpunit/phpunit 4.8.x-dev requires phpunit/php-timer ^1.0.6 -> satisfiable by phpunit/php-timer[1.0.6, 1.0.7, 1.0.8].
        - Can only install one of: phpunit/php-timer[dev-master, 1.0.6].
        - Can only install one of: phpunit/php-timer[dev-master, 1.0.7].
        - Can only install one of: phpunit/php-timer[dev-master, 1.0.8].
        - Installation request for phpunit/php-timer (locked at dev-master) -> satisfiable by phpunit/php-timer[dev-master].




      [Exception]
      Error with installing plugin


  • 3 Comments sorted by
  • Hello Radu,

    Try backing up everything, and then deleting composer.lock in your main newscoop directory, before installing the plugin again.

    (A new composer.lock file should be created when the plugin is installed - you will find the problem arises because the standard composer.lock file specifies development instead of production versions of files).
  • Hi Said! The solution that you propose, don`t work. But the problem is the same
  • Hi Said! The solution that you propose, don`t work. But the problem is the same