automated booktype install ubuntu 14.04 lts - virtualenv dependency error
  • I'm following the instructions posted here:

    It is all very straight forward, but not working.

    root@ubuntu:~# apt-get install booktype
    Reading package lists... Done
    Building dependency tree       
    Reading state information... Done
    Some packages could not be installed. This may mean that you have
    requested an impossible situation or if you are using the unstable
    distribution that some required packages have not yet been created
    or been moved out of Incoming.
    The following information may help to resolve the situation:

    The following packages have unmet dependencies:
     booktype : PreDepends: virtualenv but it is not installable
    E: Unable to correct problems, you have held broken packages.

    It's asking for a package that ubuntu doesn't know about.

    root@ubuntu:~# apt-get install virtualenv
    Reading package lists... Done
    Building dependency tree      
    Reading state information... Done
    Package virtualenv is not available, but is referred to by another package.
    This may mean that the package is missing, has been obsoleted, or
    is only available from another source

    E: Package 'virtualenv' has no installation candidate

    Can someone tell me what the name of the package is I'm missing?  Because there isn't a literal "virtualenv" package to be installed.  I've tried a few of the derivitive packages that look similar, but all have yielded the same error.

  • 1 Comment sorted by
  • Vote Up0Vote Down Daniel JamesDaniel James
    Posts: 844Member, Sourcefabric Team
    Hi Andrew,

    This is a bit odd, because the 'virtualenv' package does not appear until Ubuntu Vivid (15.04) and has a dependency on Python 3, which you do not need for Booktype. I'm guessing you have tried to update your Ubuntu 14.04 system at some point using repositories for a later version of Ubuntu. The files under /etc/apt/sources.list.d/ may indicate this.

    In Ubuntu 14.04 the package is called 'python-virtualenv' but you will not be able to install it until you have corrected the broken package issue.

    My suggestion would be to check the sources list files, comment out anything that isn't Ubuntu Trusty, and remove any broken packages manually with Synaptic, like this:

    then confirm that all is well before proceeding.
    Please let us know how you get on!