Upload not working for larger mp3 file
  • I'm trying to upload an mp3 recording of about an hour, total file size is a little over 100MB.
    It starts the upload but halfway through, a message 'upload failed. try again' appears and the upload stops.
    I have no idea what logfile to look into (the docker-script starts as an @reboot in crontab), so no idea what goes wrong.

    What are the limitations in size and type of uploaded files?
    What process or service limit those uploads? PHP, the docker subsystem, ...
    Where can those size limitations be altered/changed?

    Thanks guys!
    It's looking really good! Hopefully fully operational in a couple of days so we can start looking around, configuring and setting up groups and rights and uploading our historical data from the last year or so in a couple of weeks and have it all readied-up for next working year, starting after the summer.

  • 3 Comments sorted by
  • Superdesk backend is proxied by nginx (https://github.com/superdesk/superdesk/blob/master/client/superdesk_vhost.conf).
    After holidays i will adjust it's config and commit the changes to superdesk repo.
    Innovations developer, Sourcefabric
  • What config (parameter) needs to be changed? Is there anything I can test already?

    I'm not really acquainted with nginx config files, so no idea where to look or what to change.

    Thank you so much!
  • Hello Bram!
    Sorry, I didn't have a time to test it, i think the needed option is http://nginx.org/en/docs/http/ngx_http_core_module.html#client_max_body_size

    If that did not helped you can observe nginx logs on superdesk-client container (connect to it with "docker exec -ti $CONTAINER_NAME bash").
    Innovations developer, Sourcefabric