Booktype 2.0 Demo - can't create Section/Chapter
  • Hi,

    I assume I'm doing something stupid here as I can see that others have been able to create content for their books on the 2.0 Demo site, but I can't create a new section (and hence any new chapters).

    I've created an account, logged in, created a new book (private for now).

    However, when I edit the book, click the "New Section" button, fill in the section name and then click the "Create Section" button, I just get a simple dialog saying "Couldn't create section".

    Could this be because I've made the Visibility setting "Private".  I've tried to edit the book settings to change that, but when I click on the "Visibility" link on the Settings page, I get a message saying "Settings Module not available".


    Rob Hills
    Waikiki, Western Australia
  • 4 Comments sorted by
  • How useful is a Demo if you can't do anything with it?

    I've looked around further and AFAICT, I only have a "reader" role available for the book I've created.  Is that why I can't edit it?  I'd have thought that by default, if someone could create a book they should have permission to edit it.  How do I get that permission?

    I still can't add a Section or a Chapter.
  • Hi Rob!

    Well, there is no reason why you shouldn't be able to create new Section or Chapter on your own book. You are owner of that book and clearly have all the required permissions for this. I just checked it on the demo site with my test book and it works. Can you try it again and if it does not work can you write username and book name (or send me message) and I will check it out.

  • Hi Aco,
    Thanks for the reply.  I just tried again and still couldn't create a new section.  My login on the test book site is "rhills" and the book is the only one there, named "NEW Test Book for FSC".

    It'd be good to find out why I can't add sections/chapters.  From what you say should be happening, this sounds like a weird bug.

    Rob Hills
  • Hi Rob,

    I just realised that you wrote booktype-dev was a demo server. No sorry, is our demo server. It is older version of Booktype.

    booktype-dev is our development server with latest Booktype 2.0. It can easily be broken or down sometimes, as was in your case. Considering some of the main features are missing there, it should not be taken as some kind of demo for now. But we are back on polishing Booktype 2.0 for the testing phase so I hope there would be less and less of that.