× Warning! This forum is in archival status. New contributions may not work.
Install error with django-admin.py syncdb --noinput --> settings.DATABASES is improperly configured
  • Hi all,

    I'm currently installing Booktype by following the doc

    which is on the Booktype wiki, on a brand new server (Last Ubuntu)

    and there's an error when I type the command :

    django.admin.py syncdb --noinput

    It displays : "ImproperlyConfigured: settings.DATABASES

    is improperly configured. Please supply the NAME value".

    Any experience or help would be appreciated.

    Thanks for reading.

    Have a nice day,

    Cam

    Post edited by Camille at 2014-12-02 09:00:49
  • 2 Comments sorted by
  • Hi !
    Any idea about this issue ?

    Best regards,
    Cam
  • Hi Camille!

    I know I am late but still, it would be good to get answer just in case someone finds the question here on the forum.

    You need to edit settings file. This is in case of Booktype 1.6 and Booktype 2.0. It is this part of the settings. You need to define NAME value (and USER/PASSWORD) if using PostgreSQL.

    DATABASES = {'default': {
                             'ENGINE': 'django.db.backends.postgresql_psycopg2',
                             'NAME': '',
                             'USER': '',
                             'PASSWORD': '',
                             'HOST': 'localhost',
                             'PORT': ''
                            }
                }



     Createbooki/Createbooktype script will create database name when Sqlite3 is selected as database. In case of the PostgreSQL, you have to manually define the settings for the database, create the database, set up permissions on it and etc.