× Warning! This forum is in archival status. New contributions may not work.
Fix for failed install - Postgres Database is not UTF8
  • The Postgres install - not UTF8 - aborts the install. The test is FLAWED.
    The installer checks if the POSTGRES database is is UTF8 if not it aborts
    the whole shebang. No amount of changing the locale to UTF8 will make any difference to the test.
    It doesn't matter if the postgres is UTF8. The Airtime can be forced to UTF8 independently.
    The standard advice to uninstall postgresql and reinstall doesn't work either because that does not remove the problem - when reinstalled it will keep the old encoding.
    -------------------------------------------------
    This rescues it:

    su root

    Reconfigure your local settings :

    dpkg-reconfigure locale

    Choose your locale (like for instance : en:US.UTF8)

    Uninstall and clean properly postgresql :

    apt-get --purge remove postgresql\*
    rm -r /etc/postgresql/
    rm -r /etc/postgresql-common/
    rm -r /var/lib/postgresql/
    userdel -r postgres
    groupdel postgres

    Re-install postgresql :

    aptitude install postgresql-9.1 postgresql-contrib-9.1 postgresql-doc-9.1

    Now any new database will be automatically be created with correct encoding, LC_TYPE (character classification), and LC_COLLATE (string
    sort order)
    Post edited by John Chewter at 2014-09-20 08:50:45
    No longer using Airtime or Libretime.