Installed in Google App Engine but admin is empty
  • Hi,
    I've installed Live Blog using Google App Engine computer and followed every step in the install guide. Everything seems to start fine but when I try to access the admin interface I'm only getting one word "SuperDesk" in the top and it links back to the adminpage. Is there something I'm missing here?

    This is the output I'm getting when starting Live Blog:

    INFO     Nothing to report for 'Active rights', everything fits nicely                              

    INFO     Nothing to report for 'Captcha gateways', everything fits nicely                           

    INFO     Nothing to report for 'Users gateways', everything fits nicely                             

    INFO     Nothing to report for 'Anonymous gateways', everything fits nicely                         

    INFO     Published text fixtures from '/home/espengrimsgaard/ally-py/live-blog/distribution/plugins/' to 'tests' __plugin__.support_testing.publish_test_fixtures

    INFO     Published themes from '/home/espengrimsgaard/ally-py/live-blog/distribution/plugins/' to 'lib/livedesk-embed' __plugin__.livedesk_embed.theme_default

    INFO     Nothing to report for 'Server', everything fits nicely                                     

    INFO     Registering 62 services into the resources structure                                                 __setup__.ally_core.resources

    INFO     ================================================== Started Async HTTP server...                      ally.http.server.server_asyncore

    ================================================== Application started in 4.10 seconds

  • 5 Comments sorted by
  • This log is showing that everything worked well.
    Now the question is why isn't it working? there are two possibilities

    1) there is a proxy which is routing to something else.
    2) the default port in the configuration is 8080 maybe you didn't access the right server and port. 
  • Can you provide more details or some screen shoots on this behavior, maybe we can help more.
  • I figured it out, I installed it in my home directory, but after uninstalling and installing it in /opt instead it works like a charm :-) (So to be honest I failed following the instructions :-S)

    I had to use sudo on every command though, and I also have to run Live Blog with root access but do you think that would be a problem?

    In the terminal I'm getting

    ERROR    Exception occurred while writing to the connection '<socket.socket object, fd=46, family=2, type=2049, proto=0>' ally.http.server.server_asyncore

    Traceback (most recent call last):

      File "/opt/ally-py/live-blog/distribution/components/", line 244, in _3_handle_write

        else: sent = self.send(data)

      File "/usr/lib/python3.2/", line 374, in send

        result = self.socket.send(data)

    socket.error: [Errno 110] Connection timed out

    sometimes but I'm not sure what it means and if it's related to running it as root?

    One more thing. I'm just for the moment trying the cheapest version (standard) of Google App Engine, but the cpu is at 100% all the time. Is that normal? :)
    Post edited by Espen Grimsgaard at 2014-05-22 10:20:56
  • I'm writing Google App Engine all the time, but I'm actually meaning Google Compute Engine.. Sorry about that.
  • I tried to create a new vm instance on GCE with 2 vCPUs and 7,8GB memory and now the load is at 2% instead. I'm not really sure why - I use the same disk instance but as long as it works I'm happy :)