New Airtime installation, liquidsoap acting up?


  • So.  New Airtime installation...everything seems to be running great, icecast works fine, but it looks like liquidsoap appears to just be doing...nothing.  I've checked the monit instance, and liquidsoap gives an 'execution failed' error.  I've tried doing a manual stop and start (as per the troubleshooting guide), and I get:

    Starting Liquidsoap Playout Engine: start-stop-daemon: unable to alter nice level by -15 (Operation not permitted)
    Done.

    Then, the red "on air" light goes on with the airtime webpage for about 20 seconds, then goes off.

    I've tried checking the logs.  the /var/log/airtime/pypo-liquidsoap directory is empty for some reason. The /var/log/airtime/pypo/pypo.log, however, keeps going:

    2014-04-21 21:46:08,683 DEBUG - [pypocli.py : liquidsoap_get_info() : line 162] - Checking to see if Liquidsoap is running
    2014-04-21 21:46:08,684 ERROR - [pypocli.py : liquidsoap_get_info() : line 171] - [Errno 111] Connection refused
    2014-04-21 21:46:08,684 WARNING - [pypocli.py : liquidsoap_startup_test() : line 198] - Liquidsoap doesn't appear to be running!, Sleeping and trying again

    Anyways, I'm a bit stumped.  Any ideas?

    Thanks in advance!
    Post edited by Rob Mitzel at 2014-04-22 12:15:55
  • 13 Comments sorted by
  • Here's my results of airtime-check-system:

    AIRTIME_STATUS_URL             = http://localhost:80/api/status/format/json/api_key/%%api_key%%
    AIRTIME_SERVER_RESPONDING      = OK
    KERNEL_VERSION                 = 2.6.32-5-vserver-amd64
    MACHINE_ARCHITECTURE           = x86_64
    TOTAL_MEMORY_MBYTES            = 1048576
    TOTAL_SWAP_MBYTES              = 0
    AIRTIME_VERSION                = 2.5.1
    OS                             = Debian GNU/Linux 7.4 (wheezy) x86_64
    cat: write error: Broken pipe
    CPU                            = Intel(R) Xeon(R) CPU           E5649  @ 2.53GHz
    WEB_SERVER                     = Apache/2.2.22 (Debian)
    PLAYOUT_ENGINE_PROCESS_ID      = 4405
    PLAYOUT_ENGINE_RUNNING_SECONDS = 166650
    PLAYOUT_ENGINE_MEM_PERC        = 1.4%
    PLAYOUT_ENGINE_CPU_PERC        = 0.0%
    LIQUIDSOAP_PROCESS_ID          = FAILED
    LIQUIDSOAP_RUNNING_SECONDS     = 0
    LIQUIDSOAP_MEM_PERC            = 0%
    LIQUIDSOAP_CPU_PERC            = 0%
    tail: cannot open `/var/log/airtime/pypo-liquidsoap/ls_script.log' for reading: No such file or directory
    -- Displaying log file /var/log/airtime/pypo-liquidsoap/ls_script.log
    --
    --
    MEDIA_MONITOR_PROCESS_ID       = 30400
    MEDIA_MONITOR_RUNNING_SECONDS  = 165759
    MEDIA_MONITOR_MEM_PERC         = 1.6%
    MEDIA_MONITOR_CPU_PERC         = 0.0%
    -- There appears to be a problem with your Airtime installation.
    -- Please visit http://wiki.sourcefabric.org/x/HABQ

    Just FYI, I've checked that wiki page, and it has nothing to do with what the problem is (as far as I can see). Help? :)
  • Your Icecast is not connecting to liquidsoap,
    Check the settings password etc.

    as a last case purge and reinstall icecast

    Good luck
    VOISSES
    Anyone reading this a find it funny about my grammar , I make no apology ,Go get a translator.
    "The Problem with education today is that it takes a university degree to switch on a light bulb"
    "You learn from your mistakes but wise people learn from others mistakes avoid Making mistakes there is not sufficient rooms to make them"
    "Innuendo","If's","Assumptions" and "Fear" are for politician.Who,What,where,When and How are for those seeking knowledge and care about Humanity.
    "I might be in Mud but that does not Make me a Wild Hog(pig)"
    “Any intelligent fool can make things bigger, more complex, and more violent. It takes a touch of genius — and a lot of courage to move in the opposite direction.”
    "The only thing that remains constant is change itself"
    May the force be with you,until our path or destiny bring us in tandem.
  • Icecast works fine.  I've connected to it via sources other than airtime, and it runs great.

    I've checked the passwords and such via the stream settings on airtime, too.

    Anything else?  I suspect that reinstalling Icecast won't really help much. :(
  • Ooops too much homebrew easter bun!
    8-}

    Try this

    Sudo touch /var/log/airtime/pypo-liquidsoap/ls_script.log

    it may require the permission rights or permission
    try
    Sudo chmod 775 /var/log/airtime/pypo-liquidsoap/ls_script.log

    if not try 777

    I notice that for sure,that the logs were not created in some installation case

    Good luck
    Voisses
    Anyone reading this a find it funny about my grammar , I make no apology ,Go get a translator.
    "The Problem with education today is that it takes a university degree to switch on a light bulb"
    "You learn from your mistakes but wise people learn from others mistakes avoid Making mistakes there is not sufficient rooms to make them"
    "Innuendo","If's","Assumptions" and "Fear" are for politician.Who,What,where,When and How are for those seeking knowledge and care about Humanity.
    "I might be in Mud but that does not Make me a Wild Hog(pig)"
    “Any intelligent fool can make things bigger, more complex, and more violent. It takes a touch of genius — and a lot of courage to move in the opposite direction.”
    "The only thing that remains constant is change itself"
    May the force be with you,until our path or destiny bring us in tandem.
  • haha, no problem. :P

    Tried recreating the logfile and chmod'ing it to both, no go.

    Anything else I should try?
  • As an addendum, I've ran 'airtime-log -t' to see what I can see. 

    /var/log/airtime/pypo-liquidsoap/ls_script.log is still showing up blank.

    /var/log/airtime/pypo/pypo.log is repeating:

    2014-04-24 16:27:34,478 DEBUG - [pypocli.py : liquidsoap_get_info() : line 162] - Checking to see if Liquidsoap is running
    2014-04-24 16:27:34,478 ERROR - [pypocli.py : liquidsoap_get_info() : line 171] - [Errno 111] Connection refused
    2014-04-24 16:27:34,479 WARNING - [pypocli.py : liquidsoap_startup_test() : line 198] - Liquidsoap doesn't appear to be running!, Sleeping and trying again

    Im beating my head against the wall, my boss is screaming at me, and I'm tempted to dump the whole thing and see if there's some other way to do this (even though there isn't.)  Can anyone else help? Please?
  • Vote Up0Vote Down Cliff WangCliff Wang
    Posts: 339Member, Sourcefabric Team
    Whats it say:

    sudo -u pypo /usr/lib/airtime/pypo/bin/airtime-liquidsoap
    Cloud Radio -> http://airtime.pro
  • Running right now, so far all I've gotten was:

    #########################################
    #           *** pypo  ***               #
    #     pypo notification gateway         #
    #########################################

    I'll wait and see if there's anything else.

    I have a really dumb question though.  My /etc/airtime/liquidsoap.cfg file is blank.  It's always been blank.  Is that normal?

  • This is bizzare.  I ran this before Cliff's last post:

    ls -l
    total 28
    -rw-r----- 1 www-data www-data  473 Apr 18 19:09 airtime.conf
    -rw-r--r-- 1 root     root      129 Dec 18 08:49 airtime.ini
    -rw-r--r-- 1 root     root      254 Feb 11  2013 apache.conf
    -rw-r--r-- 1 root     root      472 Sep  1  2011 apache.vhost.tpl
    -rw-r----- 1 pypo     pypo      132 Apr 18 19:09 api_client.cfg
    -rw-r--r-- 1 pypo     pypo        0 Apr 24 16:42 liquidsoap.cfg
    -rw-r----- 1 pypo     pypo      932 Apr 24 06:21 media-monitor.cfg
    -rw-r----- 1 pypo     pypo     2688 Apr 24 06:21 pypo.cfg

    Now, suddenly, I get this:

    ls -l
    total 32
    -rw-r----- 1 www-data www-data  473 Apr 18 19:09 airtime.conf
    -rw-r--r-- 1 root     root      129 Dec 18 08:49 airtime.ini
    -rw-r--r-- 1 root     root      254 Feb 11  2013 apache.conf
    -rw-r--r-- 1 root     root      472 Sep  1  2011 apache.vhost.tpl
    -rw-r----- 1 pypo     pypo      132 Apr 18 19:09 api_client.cfg
    -rw-r--r-- 1 pypo     pypo     1410 Apr 24 16:46 liquidsoap.cfg
    -rw-r----- 1 pypo     pypo      932 Apr 24 06:21 media-monitor.cfg
    -rw-r----- 1 pypo     pypo     2688 Apr 24 06:21 pypo.cfg

    ...featuring a full liquidsoap configuration.  How odd.
  • Vote Up0Vote Down Cliff WangCliff Wang
    Posts: 339Member, Sourcefabric Team
    Yeah, the output is normal. And liquidsoap.cfg's contents is generated automatically if it's running successfully.

    try:
    sudo service airtime-liquidsoap start && sudo airtime-check-system

    to see what happens
    Cloud Radio -> http://airtime.pro
  • Like My thoughts are

    This is a connection issue,I had this problem with an upgrade cannot tell now.

    There is two things you can do further

    1. push a signal through the liquidsoap like a sine wave I think its liquidsoap -h sine to check the output  ( i will correct this in te morning too tired now)
    2. push a playlist via liquidsoap and Icecast and check the logs

    Both are just confrimatiion that liquidsoap and Icecast are ok


    My biggest concerns are

    • what version of liquidsoap is on  this machine (liquidsoap - version) or
    • Is this a vanilla or mod liquidsoap script

    Good Luck see You soon

    Voisses

    Ps @cliiff wang,I totally forgot to mention do a restart


    Post edited by Voisses Tech at 2014-04-24 23:37:04
    Anyone reading this a find it funny about my grammar , I make no apology ,Go get a translator.
    "The Problem with education today is that it takes a university degree to switch on a light bulb"
    "You learn from your mistakes but wise people learn from others mistakes avoid Making mistakes there is not sufficient rooms to make them"
    "Innuendo","If's","Assumptions" and "Fear" are for politician.Who,What,where,When and How are for those seeking knowledge and care about Humanity.
    "I might be in Mud but that does not Make me a Wild Hog(pig)"
    “Any intelligent fool can make things bigger, more complex, and more violent. It takes a touch of genius — and a lot of courage to move in the opposite direction.”
    "The only thing that remains constant is change itself"
    May the force be with you,until our path or destiny bring us in tandem.
  • Well.  I actually decided to gut the whole installation and try again from scratch. I had to run pypo-liquidsoap manually again, but otherwise....I did the test tone on liquidsoap (worked fine), then uploaded some songs and did a playlist, then scheduled it...and guess what?  It runs great now.

    So yeah, other than having to su into pypo and running the liquidsoap script manually (which isn't a long-term solution), things work fine.

    So what do I do about the remaining issue?  Any ideas?

    PS thanks again for all your help btw, Cliff and Voisses!
  • Vote Up0Vote Down sumansuman
    Posts: 1Member
    I have exactly same error and corrected by adding "allow localhost" to
    /etc/monit/conf.d/monit-airtime-generic.cfg
    now working