× Warning! This forum is in archival status. New contributions may not work.
after changing ports to 8080 airtime fails
  • Hi Folks!

    I am quite frustated with a problem, many folks seem to have..

    I am running on a stratoserver an airtime and an drupal installation

    drupal installation shall be the standart application for those who want to hear the radio station (frontend)
    airtime is of course the backend

    in port 80 the whole airtime out of the box installation works fine, but when I am changing the /etc/airtime/api_client.cfg and the /etc/airtime/airtime.conf to the ports 8080 and of course the vhost I get the following problem

    PLAYOUT_ENGINE_PROCESS_ID      = FAILED
    LIQUIDSOAP_PROCESS_ID          = FAILED
    MEDIA_MONITOR_PROCESS_ID       = FAILED

    For those who need the whole airtime check I post it below....

    Thanks for your help in advance...

    me@server:~# airtime-check-system
    AIRTIME_STATUS_URL             = http://localhost:8080/api/status/format/json/api_key/%%api_key%%
    AIRTIME_SERVER_RESPONDING      = OK
    KERNEL_VERSION                 = UNKNOWN
    MACHINE_ARCHITECTURE           = UNKNOWN
    TOTAL_MEMORY_MBYTES            = UNKNOWN
    TOTAL_SWAP_MBYTES              = UNKNOWN
    AIRTIME_VERSION                = UNKNOWN
    OS                             = Ubuntu 12.04.3 LTS i686
    CPU                            = AMD Opteron(tm) Processor 6128
    WEB_SERVER                     = Apache/2.2.22 (Ubuntu)
    PLAYOUT_ENGINE_PROCESS_ID      = FAILED
    PLAYOUT_ENGINE_RUNNING_SECONDS = 0
    PLAYOUT_ENGINE_MEM_PERC        = 0%
    PLAYOUT_ENGINE_CPU_PERC        = 0%
    -- Displaying log file /var/log/airtime/pypo/pypo.log
    -- 2014-01-28 21:13:44,272 DEBUG - [api_client.py : get_stream_parameters() : line 504] - {u'stream_params': {u's3': {u'admin_pass': u'', u'enable': u'false', u'description': u'', u'url': u'', u'bitrate': u'', u'mount': u'', u'channels': u'stereo', u'host': u'', u'admin_user': u'', u'user': u'', u'pass': u'', u'genre': u'', u'output': u'icecast', u'type': u'', u'port': u'', u'name': u''}, u's2': {u'admin_pass': u'', u'enable': u'false', u'description': u'', u'url': u'', u'bitrate': u'', u'mount': u'', u'channels': u'stereo', u'host': u'', u'admin_user': u'', u'user': u'', u'pass': u'', u'genre': u'', u'output': u'icecast', u'type': u'', u'port': u'', u'name': u''}, u's1': {u'admin_pass': u'', u'enable': u'true', u'description': u'Airtime Radio! Stream #1', u'url': u'http://airtime.sourcefabric.org', u'bitrate': u'128', u'mount': u'airtime_128', u'liquidsoap_error': u'401, Authentication Required (HTTP/1.0)', u'channels': u'stereo', u'host': u'127.0.0.1', u'admin_user': u'', u'user': u'', u'pass': u'hackme', u'genre': u'genre', u'output': u'icecast', u'type': u'ogg', u'port': u'8000', u'name': u'Airtime!'}}}
    -- 2014-01-28 21:13:44,460 DEBUG - [api_client.py : __call__() : line 134] - http://localhost:80/api/update-stream-setting-table/api_key/JZRA3594I5JAXES3SRP9/format/json
    -- 2014-01-28 21:15:44,772 DEBUG - [api_client.py : __call__() : line 134] - http://localhost:80/api/get-stream-parameters/api_key/JZRA3594I5JAXES3SRP9/format/json
    -- 2014-01-28 21:15:44,871 DEBUG - [api_client.py : get_stream_parameters() : line 504] - {u'stream_params': {u's3': {u'admin_pass': u'', u'enable': u'false', u'description': u'', u'url': u'', u'bitrate': u'', u'mount': u'', u'channels': u'stereo', u'host': u'', u'admin_user': u'', u'user': u'', u'pass': u'', u'genre': u'', u'output': u'icecast', u'type': u'', u'port': u'', u'name': u''}, u's2': {u'admin_pass': u'', u'enable': u'false', u'description': u'', u'url': u'', u'bitrate': u'', u'mount': u'', u'channels': u'stereo', u'host': u'', u'admin_user': u'', u'user': u'', u'pass': u'', u'genre': u'', u'output': u'icecast', u'type': u'', u'port': u'', u'name': u''}, u's1': {u'admin_pass': u'', u'enable': u'true', u'description': u'Airtime Radio! Stream #1', u'url': u'http://airtime.sourcefabric.org', u'bitrate': u'128', u'mount': u'airtime_128', u'liquidsoap_error': u'401, Authentication Required (HTTP/1.0)', u'channels': u'stereo', u'host': u'127.0.0.1', u'admin_user': u'', u'user': u'', u'pass': u'hackme', u'genre': u'genre', u'output': u'icecast', u'type': u'ogg', u'port': u'8000', u'name': u'Airtime!'}}}
    -- 2014-01-28 21:15:45,125 DEBUG - [api_client.py : __call__() : line 134] - http://localhost:80/api/update-stream-setting-table/api_key/JZRA3594I5JAXES3SRP9/format/json
    --
    --
    LIQUIDSOAP_PROCESS_ID          = FAILED
    LIQUIDSOAP_RUNNING_SECONDS     = 0
    LIQUIDSOAP_MEM_PERC            = 0%
    LIQUIDSOAP_CPU_PERC            = 0%
    -- Displaying log file /var/log/airtime/pypo-liquidsoap/ls_script.log
    -- 2014/01/28 21:16:36 [stdout:3] #########################################
    -- 2014/01/28 21:16:40 [airtime_128:3] Connecting mount airtime_128 for source@127.0.0.1...
    -- 2014/01/28 21:16:40 [airtime_128:2] Connection failed: 401, Authentication Required (HTTP/1.0)
    -- 2014/01/28 21:16:40 [lang:3] /usr/lib/airtime/pypo/bin/liquidsoap_scripts/notify.sh --error='401, Authentication Required (HTTP/1.0)' --stream-id=1 --time=1390939900.53 &
    -- 2014/01/28 21:16:40 [airtime_128:3] Will try again in 5.00 sec.
    --
    --
    MEDIA_MONITOR_PROCESS_ID       = FAILED
    MEDIA_MONITOR_RUNNING_SECONDS  = 0
    MEDIA_MONITOR_MEM_PERC         = 0%
    MEDIA_MONITOR_CPU_PERC         = 0%
    -- Displaying log file /var/log/airtime/media-monitor/media-monitor.log
    -- 2014-01-28 21:13:15,781 INFO - [Thread-3] [watchersyncer.py : push_request()] : LINE 146 - WatchSyncer : Unleashing request
    -- 2014-01-28 21:13:15,782 INFO - [Thread-6] [request.py : run_request()] : LINE 34 - Attempting request with 1 items.
    -- 2014-01-28 21:13:15,789 INFO - [Thread-6] [api_client.py : send_media_monitor_requests()] : LINE 359 - Pumping out 1 requests...
    -- 2014-01-28 21:13:15,790 DEBUG - [Thread-6] [api_client.py : __call__()] : LINE 134 - http://localhost:80/api/reload-metadata-group/format/json/api_key/JZRA3594I5JAXES3SRP9
    -- 2014-01-28 21:13:15,960 INFO - [Thread-6] [request.py : run_request()] : LINE 54 - Request was successful
    --
    --
    -- There appears to be a problem with your Airtime installation.
    -- Please visit http://wiki.sourcefabric.org/x/HABQ
     
  • 12 Comments sorted by
  • Sounds like you have a firewall installed and port 8080 is not opened.
    No longer using Airtime or Libretime.
  • No, sorry my webmin says there is all traffic allowed
    no firewall installed,
    there is not such file like /etc/iptables.up.rules
  • You need to place the port in your apache configuration like this (your apache only listen on port 80 by default)

    Listen 8080

    This is not mention in The Faq

    You will find this tutorial http://forum.sourcefabric.org/discussion/comment/27908  in the second part to be of great help

    Oh and remember to reload and restart your apache server
    Anyone reading this a find it funny about my grammar , I make no apology ,Go get a translator.
    "The Problem with education today is that it takes a university degree to switch on a light bulb"
    "You learn from your mistakes but wise people learn from others mistakes avoid Making mistakes there is not sufficient rooms to make them"
    "Innuendo","If's","Assumptions" and "Fear" are for politician.Who,What,where,When and How are for those seeking knowledge and care about Humanity.
    "I might be in Mud but that does not Make me a Wild Hog(pig)"
    “Any intelligent fool can make things bigger, more complex, and more violent. It takes a touch of genius — and a lot of courage to move in the opposite direction.”
    "The only thing that remains constant is change itself"
    May the force be with you,until our path or destiny bring us in tandem.
  • Thanks Voisses !

    In the ports.conf I find follwing lines already

    NameVirtualHost *
    NameVirtualHost *:80
    Listen *:80
    Listen *:8080

    this means to me, that apache should listen to 8080 also...

    So what should I do?

    In your link you are suggesting seperate ports for small environments, but as I understand 80 and 8080 are already seperate ports. But airtime can not use them as airtime check is mentioning...
    1-
      Separate ports   - Single Network card  - A fixed IP is recommended
    (my preference for small environments) - See more at:
    http://forum.sourcefabric.org/discussion/comment/27908#sthash.0KE3zqZt.dpuf
    1-
      Separate ports   - Single Network card  - A fixed IP is recommended
    (my preference for small environments) - See more at:
    http://forum.sourcefabric.org/discussion/comment/27908#sthash.0KE3zqZt.dpuf
    1-
      Separate ports   - Single Network card  - A fixed IP is recommended
    (my preference for small environments) - See more at:
    http://forum.sourcefabric.org/discussion/comment/27908#sthash.0KE3zqZt.dpuf
    1-
      Separate ports   - Single Network card  - A fixed IP is recommended
    (my preference for small environments) - See more at:
    http://forum.sourcefabric.org/discussion/comment/27908#sthash.0KE3zqZt.dpuf


  • You might be able to do some black magic with .htaccess.
    Something like this - UNTESTED:

    RewriteCond %{HTTP_HOST} ^sub.website.com:8080$ [NC]
    RewriteCond %{SERVER_PORT} ^8080$
    RewriteRule ^(.*)$ https://sub.website.com:80/$1 [L,R=302]
    Post edited by John Chewter at 2014-01-28 18:56:22
    No longer using Airtime or Libretime.
  • The problem is 2 fold  (airtime and Icecast)
    with airtime the api client is not on the port 8080
     from this line

    - 2014-01-28 21:13:44,460 DEBUG - [api_client.py : __call__() : line 134] - http://localhost:80/api/update-stream-setting-table/api_key/JZRA3594I5JAXES3SRP9/format/json
    -- 2014-01-28 21:15:44,772 DEBUG - [api_client.py : __call__() : line 134] - http://localhost:80/api/get-stream-parameters/api_key/JZRA3594I5JAXES3SRP9/format/json
    -- 2014-01-28 21:15:44,871 DEBUG - [api_client.py : get_stream_parameters() : line 504]


    From Icecast
    From this line

    -- 2014/01/28 21:16:40 [airtime_128:3] Connecting mount airtime_128 for source@127.0.0.1...
    -- 2014/01/28 21:16:40 [airtime_128:2] Connection failed: 401, Authentication Required

    You should not have to rewrite anything in the htaccess.


    @olim devona

    could you ensure your  airtimevirtulalhost.conf  sites-available and sites-enable are the same.

    if they are not  you need to reload apache in addition to restart.

    Please post the  airtime virtual host conf. so I can see it

    If purging and reinstall is an option ( because you have done so much changes you are confused)

    Then i suggest you do so but also remove the airtime virtual conf in your sites-available and reload apache
    ensure that there is no airtime virtual host in sites-enable



    Anyone reading this a find it funny about my grammar , I make no apology ,Go get a translator.
    "The Problem with education today is that it takes a university degree to switch on a light bulb"
    "You learn from your mistakes but wise people learn from others mistakes avoid Making mistakes there is not sufficient rooms to make them"
    "Innuendo","If's","Assumptions" and "Fear" are for politician.Who,What,where,When and How are for those seeking knowledge and care about Humanity.
    "I might be in Mud but that does not Make me a Wild Hog(pig)"
    “Any intelligent fool can make things bigger, more complex, and more violent. It takes a touch of genius — and a lot of courage to move in the opposite direction.”
    "The only thing that remains constant is change itself"
    May the force be with you,until our path or destiny bring us in tandem.
  • I recommend separate ports because you will see the benefits by using any intrusion detection (like snort).

    It provides better leverage and You can also do a lot if you have multiple server behind your main server or uses a reverse proxy and some form of load balancing
    Anyone reading this a find it funny about my grammar , I make no apology ,Go get a translator.
    "The Problem with education today is that it takes a university degree to switch on a light bulb"
    "You learn from your mistakes but wise people learn from others mistakes avoid Making mistakes there is not sufficient rooms to make them"
    "Innuendo","If's","Assumptions" and "Fear" are for politician.Who,What,where,When and How are for those seeking knowledge and care about Humanity.
    "I might be in Mud but that does not Make me a Wild Hog(pig)"
    “Any intelligent fool can make things bigger, more complex, and more violent. It takes a touch of genius — and a lot of courage to move in the opposite direction.”
    "The only thing that remains constant is change itself"
    May the force be with you,until our path or destiny bring us in tandem.






  • P { margin-bottom: 0.21cm; }


    Hey Voisses!

    I apology for
    delay. here you are the site_available airtime vhost config...



    sites-available





    <VirtualHost
    xn--weltempfnger-ncb.net:8080>


    ServerAdmin
    webmaster@localhost


    DocumentRoot /usr/share/airtime/public


    php_admin_value upload_tmp_dir /tmp




    <Directory
    /usr/share/airtime/public>


    DirectoryIndex index.php


    AllowOverride all


    Order allow,deny


    Allow from all


    </Directory>


    ServerName
    airtime.h2245452.stratoserver.net


    </VirtualHost>


    ~








    sites-enabled airtime config








    <VirtualHost
    xn--weltempfnger-ncb.net:8080>


    ServerAdmin
    webmaster@localhost


    DocumentRoot /usr/share/airtime/public


    php_admin_value upload_tmp_dir /tmp




    <Directory
    /usr/share/airtime/public>


    DirectoryIndex index.php


    AllowOverride all


    Order allow,deny


    Allow from all


    </Directory>


    ServerName
    airtime.h2245452.stratoserver.net


    </VirtualHost>





    On apache reload I get





    [Wed Jan 29 15:54:37 2014] [warn]
    NameVirtualHost *:80 has no VirtualHosts


    [Wed Jan 29 15:54:37 2014] [warn]
    NameVirtualHost *:0 has no VirtualHosts



    [ OK ]





    On check airtime I this (I guess
    still the same as above?)





    airtime-check-system


    AIRTIME_STATUS_URL =
    http://localhost:8080/api/status/format/json/api_key/%%api_key%%


    AIRTIME_SERVER_RESPONDING = OK


    KERNEL_VERSION =
    UNKNOWN


    MACHINE_ARCHITECTURE =
    UNKNOWN


    TOTAL_MEMORY_MBYTES =
    UNKNOWN


    TOTAL_SWAP_MBYTES =
    UNKNOWN


    AIRTIME_VERSION =
    UNKNOWN


    OS = Ubuntu
    12.04.3 LTS i686


    CPU = AMD
    Opteron(tm) Processor 6128


    WEB_SERVER =
    Apache/2.2.22 (Ubuntu)


    PLAYOUT_ENGINE_PROCESS_ID =
    FAILED


    PLAYOUT_ENGINE_RUNNING_SECONDS = 0


    PLAYOUT_ENGINE_MEM_PERC = 0%


    PLAYOUT_ENGINE_CPU_PERC = 0%


    -- Displaying log file
    /var/log/airtime/pypo/pypo.log


    -- 2014-01-29 15:52:05,766 ERROR -
    [replaygainupdater.py : run() : line 81] - HTTP Error 404: Not Found


    -- 2014-01-29 15:52:40,758 DEBUG -
    [api_client.py : __call__() : line 134] -
    http://localhost:80/api/get-stream-parameters/api_key/JZRA3594I5JAXES3SRP9/format/json


    -- 2014-01-29 15:52:40,760 ERROR -
    [listenerstat.py : run() : line 140] - Exception: HTTP Error 404: Not
    Found


    -- 2014-01-29 15:54:40,858 DEBUG -
    [api_client.py : __call__() : line 134] -
    http://localhost:80/api/get-stream-parameters/api_key/JZRA3594I5JAXES3SRP9/format/json


    -- 2014-01-29 15:54:40,860 ERROR -
    [listenerstat.py : run() : line 140] - Exception: HTTP Error 404: Not
    Found


    --


    --


    LIQUIDSOAP_PROCESS_ID =
    FAILED


    LIQUIDSOAP_RUNNING_SECONDS = 0


    LIQUIDSOAP_MEM_PERC = 0%


    LIQUIDSOAP_CPU_PERC = 0%


    -- Displaying log file
    /var/log/airtime/pypo-liquidsoap/ls_script.log


    -- 2014/01/29 15:54:42 [stdout:3]


    -- 2014/01/29 15:54:42 [stdout:3]
    #########################################


    -- 2014/01/29 15:54:42 [stdout:3] #
    *** pypo *** #


    -- 2014/01/29 15:54:42 [stdout:3] #
    pypo notification gateway #


    -- 2014/01/29 15:54:42 [stdout:3]
    #########################################


    --


    --


    MEDIA_MONITOR_PROCESS_ID =
    FAILED


    MEDIA_MONITOR_RUNNING_SECONDS = 0


    MEDIA_MONITOR_MEM_PERC = 0%


    MEDIA_MONITOR_CPU_PERC = 0%


    -- Displaying log file
    /var/log/airtime/media-monitor/media-monitor.log


    -- 2014-01-28 21:13:15,781 INFO -
    [Thread-3] [watchersyncer.py : push_request()] : LINE 146 -
    WatchSyncer : Unleashing request


    -- 2014-01-28 21:13:15,782 INFO -
    [Thread-6] [request.py : run_request()] : LINE 34 - Attempting
    request with 1 items.


    -- 2014-01-28 21:13:15,789 INFO -
    [Thread-6] [api_client.py : send_media_monitor_requests()] : LINE 359
    - Pumping out 1 requests...


    -- 2014-01-28 21:13:15,790 DEBUG -
    [Thread-6] [api_client.py : __call__()] : LINE 134 -
    http://localhost:80/api/reload-metadata-group/format/json/api_key/JZRA3594I5JAXES3SRP9


    -- 2014-01-28 21:13:15,960 INFO -
    [Thread-6] [request.py : run_request()] : LINE 54 - Request was
    successful


    --


    --


    -- There appears to be a problem with
    your Airtime installation.


    -- Please visit
    http://wiki.sourcefabric.org/x/HABQ



  • so you see your base url is pointing to localhost
    while your virtual host is pointing to  remote webserver   xxxx-ncb.net:8080

    First check your sites-enable to make sure it matches.

    Sidenote
    Apache (ubuntu) uses the sites-enable virtual hosting to serve up websites.
    The sites-enable is a soft-link (symbolic) to sites-available.
    You almost never have to change this because whenever you enable your virtual host the link is created.
    and just issuing the command sudo service apache2 reload sync both

    Recommended Solution
    • If you are hosting your airtime locally (on localhost) then change your virtual host to read that
    • if you are hosting airtime remotely(dedicated , vps or cloud then you need to change the base url in both the /etc/airtime/api_client.cfg and /etc/airtime/airtime.conf as per http://wiki.sourcefabric.org/display/CC/FAQ+and+Support under the topic How do I change the base URL or port for the web interface?


    Nb. Your post is not too clear in the forum,you can chose to make text file and attached here or place your  modified (remove important data but make clear) on pastebin (my prefered method)

    Post edited by Voisses Tech at 2014-01-29 10:40:23
    Anyone reading this a find it funny about my grammar , I make no apology ,Go get a translator.
    "The Problem with education today is that it takes a university degree to switch on a light bulb"
    "You learn from your mistakes but wise people learn from others mistakes avoid Making mistakes there is not sufficient rooms to make them"
    "Innuendo","If's","Assumptions" and "Fear" are for politician.Who,What,where,When and How are for those seeking knowledge and care about Humanity.
    "I might be in Mud but that does not Make me a Wild Hog(pig)"
    “Any intelligent fool can make things bigger, more complex, and more violent. It takes a touch of genius — and a lot of courage to move in the opposite direction.”
    "The only thing that remains constant is change itself"
    May the force be with you,until our path or destiny bring us in tandem.
  • Here is what a full configuration should look like (commands are highlighted).
    To use Airtime on different ports
    This is a localhost configuration


    pico /etc/airtime/api_client.cfg

    bin_dir = /usr/lib/airtime/api_clients
    api_key = 'xxxxxxxxxxx'
    api_base = api
    host = localhost
    base_port = 8080
    base_dir = /




    pico /etc/airtime/airtime.conf

    [general]
    api_key = xxxxxxxxxxxxxx
    web_server_user = www-data
    airtime_dir = /usr/share/airtime
    base_url = localhost
    base_port = 8080
    base_dir = /
    cache_ahead_hours = 1



    pico /etc/apache2/ports.conf
    NameVirtualHost *:80
    Listen 80

    NameVirtualHost *:8080
    Listen 8080


    pico /etc/apache2/sites-available/airtime-vhost.conf

    <VirtualHost *:8080>
          ServerName localhost
          #ServerAlias www.example.com

          ServerAdmin root@localhost

          DocumentRoot /usr/share/airtime/public
          DirectoryIndex index.php

          SetEnv APPLICATION_ENV "production"

          <Directory /usr/share/airtime/public>
                  Options -Indexes FollowSymLinks MultiViews
                  AllowOverride All
                  Order allow,deny
                  Allow from all
          </Directory>
    </VirtualHost>



     pico /etc/apache2/sites-available/default

    <VirtualHost *:80>
            ServerName mysite

            DirectoryIndex mysite
            ServerAdmin webmaster@localhost

            DocumentRoot /var/www
            <Directory />
                    Options FollowSymLinks
                    AllowOverride None
            </Directory>
            <Directory /var/www/>
                    Options Indexes FollowSymLinks MultiViews
                    AllowOverride None
                    Order allow,deny
                    allow from all
            </Directory>


    </VirtualHost>


    Note
    if you have remote serves
    Change where necessary
    • base_url          wherever.com
    • VirtualHost     <VirtualHost wherever.com:8080>  

    its best to use IP addresses if you are not confident you have a proper dns resolution




    Post edited by Voisses Tech at 2014-01-29 11:31:28
    Anyone reading this a find it funny about my grammar , I make no apology ,Go get a translator.
    "The Problem with education today is that it takes a university degree to switch on a light bulb"
    "You learn from your mistakes but wise people learn from others mistakes avoid Making mistakes there is not sufficient rooms to make them"
    "Innuendo","If's","Assumptions" and "Fear" are for politician.Who,What,where,When and How are for those seeking knowledge and care about Humanity.
    "I might be in Mud but that does not Make me a Wild Hog(pig)"
    “Any intelligent fool can make things bigger, more complex, and more violent. It takes a touch of genius — and a lot of courage to move in the opposite direction.”
    "The only thing that remains constant is change itself"
    May the force be with you,until our path or destiny bring us in tandem.
  • Now become familar with these command

    Disabling and enabling sites (vhost)


    If everything goes wrong and you are banging you head try disabling all your sites-enable* and then re-enable them again.

    *not your sites available (unless they are sites you need enable)

    You need to know your 
    ServerName :mysite

    The default site in this case is port 80. if you disable this site apache will complain with a warning

    NameVirtualHost *:80 has no VirtualHosts

    it does not affect other site on other ports (so go test the other sites and see if they work)

    sudo a2dissite mysite

    you need to reload and restart apache2 for the settings to take effect

    Tips. If you have say 10 virtual try disable all then enable 1 by 1

    To enable each one just

    sudo a2ensite mysite


    Oh and keep in mind you need to
    • reload and restart your apache
    • comment default parameters and rewrite each line (never delete or just change).
    • copy or backup configuration files before editing or modifying
    • read your logs to see whats happening when you change anything



    Post edited by Voisses Tech at 2014-01-29 12:02:16
    Anyone reading this a find it funny about my grammar , I make no apology ,Go get a translator.
    "The Problem with education today is that it takes a university degree to switch on a light bulb"
    "You learn from your mistakes but wise people learn from others mistakes avoid Making mistakes there is not sufficient rooms to make them"
    "Innuendo","If's","Assumptions" and "Fear" are for politician.Who,What,where,When and How are for those seeking knowledge and care about Humanity.
    "I might be in Mud but that does not Make me a Wild Hog(pig)"
    “Any intelligent fool can make things bigger, more complex, and more violent. It takes a touch of genius — and a lot of courage to move in the opposite direction.”
    "The only thing that remains constant is change itself"
    May the force be with you,until our path or destiny bring us in tandem.
  • After all I thought it might be more complicted, but thanks Voisses, great help....

    Everything is fine...