× Warning! This forum is in archival status. New contributions may not work.
Problem with Apache2.4
  • Hello,
    I'm trying to install Airtime on Lubuntu 13.10. I do :

    # gdebi airtime-easy-setup.deb

    Installation of airtime-easy-setup is ok.
    When I run :

    # apt-get update
    # apt-get install airtime

    I get this error :

     * Restarting web server apache2                           [fail] 
     * The apache2 configtest failed.
    Output of config test was:
    AH00526: Syntax error on line 13 of /etc/apache2/sites-enabled/airtime-vhost.conf:
    Either all Options must start with + or -, or no Option may.
    Action 'configtest' failed.
    The Apache error log may have more information.

    It seems Apache 2.4 have not the same configuration than 2.2.
    Any ideas to solve the problem?
    Thanks
    Post edited by Quentin Divay at 2013-12-05 04:26:21
  • 20 Comments sorted by
  • just edit /etc/airtime/apache.vhost.tpl as root and change the line
                  Options -Indexes FollowSymLinks MultiViews
    to look like
                  Options -Indexes +FollowSymLinks +MultiViews
    and then complete airtime setup by
    sudo apt-get install -f
    that's all ;)
    Post edited by Sergey Tuchkin at 2014-02-23 05:00:37
  • Vote Up0Vote Down Albert FRAlbert FR
    Posts: 1,978Member, Airtime Moderator
    That's normal

    First :

    in a console :

    cd /etc/apache2/sites-enabled/
    rm *

    your vhost must be named with a .conf
    for example :
    vhost-airtime -> vhost-airtime.conf

    second :

    Options -Indexes FollowSymLinks MultiViews
                  AllowOverride All
                  Order allow,deny
                  Allow from all

    Must be changed by :

    Options -Indexes +FollowSymLinks +MultiViews
                  AllowOverride All
                  Require all granted



    and first don't forgot to install php5-json (is not installed with 2.4)

    apt-get install php5-json
    Post edited by Albert FR at 2013-12-05 16:01:59
  • Thank you, I haven't tested but resolved using 'Automated Install' ;)
  • Sorry i'm wrong, automated install worked on Ubuntu Server 12.04, but i'm still getting the same error on the latest version of Ubuntu or Debian Testing.
    When I edit the file /etc/apache2/sites-availables/airtime-vhost.conf and run apt-get update, Airtime replace the file and return this error...
  • Vote Up0Vote Down Albert FRAlbert FR
    Posts: 1,978Member, Airtime Moderator
    sites-enabled ;-)

    a2ensite airtime-vhost.conf

    and before do a rm * into sites-enabled
    Post edited by Albert FR at 2013-12-11 15:53:28
  • Thanks for the tip, but it does exactly the same thing  :(
  • Vote Up0Vote Down Albert FRAlbert FR
    Posts: 1,978Member, Airtime Moderator
    not normal
    can you copy your airtime vhost configuration here ?
  • <VirtualHost *:80>
          ServerName localhost
          #ServerAlias www.example.com

          ServerAdmin root@localhost

          DocumentRoot /usr/share/airtime/public
          DirectoryIndex index.php

          SetEnv APPLICATION_ENV "production"

          <Directory /usr/share/airtime/public>
                  Options -Indexes +FollowSymLinks +MultiViews
                  AllowOverride All
                  Require all granted
          </Directory>
    </VirtualHost>


    But Airtime overwrite the file when i run apt-get update. Could you try this into ubuntu 13.10 in a VM for example? Or do you want I give you a ssh access?
  • Vote Up0Vote Down Albert FRAlbert FR
    Posts: 1,978Member, Airtime Moderator
    replace * by your ip adress
  • Yes, the full install script needs to be updated to work with the newer version of apache (2.4)
    Right now the current release of Airtime (2.5.1) is only working with php versions 5.4 (and maybe 5.3, but it's not guaranteed). Because php-apc is not supported by php 5.5 it won't install properly.
    Post edited by Naomi at 2013-12-18 12:10:15
  • Vote Up0Vote Down Albert FRAlbert FR
    Posts: 1,978Member, Airtime Moderator
    but you can use apache 2.4 with php 5.4 ;-)
    hopefully
  • yes you can use php 5.4 with apache 2.4, just our full install script does not create the vhost properly for apache 2.4 so you will have to manually change it to include the changes you have posted above :)

    Thanks for posting that!
  • Vote Up0Vote Down Albert FRAlbert FR
    Posts: 1,978Member, Airtime Moderator
    thanks to you to be more explicit than me ;-)
  • Just in case people have special options in the config, there's more details here

  • That's explain the problem ;)
    Thanks for the info, maybe for the 2.6 version of Airtime this will be updated?
  • Vote Up0Vote Down Albert FRAlbert FR
    Posts: 1,978Member, Airtime Moderator
    exactly ;-)
    2.6 will be normally fully compatible with apache2.4
  • Thanks Sergey! That's exactly what's needed..

  • I'm trying to follow the thread but at my old age I'm not getting it. Can someone post precise step by stem instruction to do this including the directory where each thing is located? Some help will be greatly appreciated. Thanks.
  • Vote Up0Vote Down hoerichhoerich
    Posts: 627Member, Airtime Moderator
    easy going, Joe.
    On Ubuntu or Debian open a Terminal.
    Then type "sudo /etc/airtime/apache.vhost.tpl" (without quotes) to open v-host-file.
    Then change the appropriate Line

                  Options -Indexes FollowSymLinks MultiViews
    to look like

                  Options -Indexes +FollowSymLinks +MultiViews


    Then close & save the file and
    in terminal type "sudo apt-get install -f"
    to complete Airtime-setup.

    good luck
    Official Airtime Forum Manager
    --------------------------
    Most of the time an issue is located between keyboard and chair.
  • Small error in your Opening of the vhost file you need a text editor to open that like vi, pico or nano. i prefer nano as i run both RHEL and Debian bases. Some people may find that frustrating especially newer people who dont know much about the shell in general


    sudo nano /etc/airtime/apache.vhost.tpl