Previously working files not playing? (2.4)
  • I'm having a really odd problem - MP3 files that used to work under 2.3 now don't work in 2.4 - just updated to the 'released' version, was RC1.

    They play in the internal player, and used to stream OK, since I updated they won't stream though - the ON AIR lights up for a few seconds, then goes out. Other files work fine, MP3 or AAC. I've tried renaming the files (they have #'s in them) but that doesn't fix it, ditto taking # out of the tags.

    Only difference I can see is these are mono 64kbs (seems to be CBR if VLC is anything to go by, bitrate doesn't shift in Media Info) MP3s and the rest are different rates...(stereo, 128kbs, VBR or 192Kbs). Has Airtime stopped working with mono files at that bitrate? Or could it be a ReplayGain issue (although I have tried turning it off, doesn't seem to 'fix' it).

    Obviously I could transcode but it would take a lot more space and be a real faff to try not to lose quality and disk space is tight.

    Any idea?
    Post edited by Tim RadioClash at 2013-06-30 20:03:52
  • 6 Comments sorted by
  • Vote Up0Vote Down Cliff WangCliff Wang
    Posts: 339Member, Sourcefabric Team
    Can you share some sample file with problem?l want to try it in my instance :)
    Cloud Radio ->
  • OK here's the one I renamed (was originally called "01 50 Pound Note Podcast - Show #8 - Xanadu.mp3") was wondering if it was choking on the hashes, but it still didn't work:

    Sadly I doubt my friend still has the source files to do a re-encode...was 7 years ago! And 54 shows...
    Post edited by Tim RadioClash at 2013-06-30 20:21:13
  • But this is specfically one of the shows I remember hearing on my 2.3 install, both the original PPC one and the more recent Ubuntu 12.04 current server - so I know it definitely used to play...
  • Vote Up0Vote Down Cliff WangCliff Wang
    Posts: 339Member, Sourcefabric Team
    Confirmed, ticket will be submitted soon. :)
    Cloud Radio ->
  • Hello,
    I seem to have this very same problem, with Airtime 2.4 too, self-hosted & installed through the apt repository. Files playing nice with 2.3.x before last week upgrade, might have in common to be of a lesser bitrate, or weird bitrate (respectively 32kbps (yessir, quality time!) and 97 kbps (don't ask)). But I can't say for sure, for I could catch and match traces/logs/files only for the last two songs with this exact same problem on this installation.

    I couldn't find any interesting log for me, nor any that i thought that might be of any use to you, but ask me any log or something, and I'll post.

    Here are the last seconds before and after the said above problem, on the pypo.log, if it can be of any help :

    2013-07-01 22:27:57,014 DEBUG - [ : queue_push() : line 89] - s0.push annotate:media_id="1843",liq_start_next="0",liq_fade_i
    2013-07-01 22:27:57,015 DEBUG - [ : queue_push() : line 95] - vars.show_name On the Fly
    2013-07-01 22:27:57,029 DEBUG - [ : queue_push() : line 98] - 1^M
    On the Fly^M
    2013-07-01 22:27:57,053 INFO - [ : main() : line 38] - waiting 135.946426s until next scheduled item

    Thanks !



    Post edited by Stephane Jourdan at 2013-07-09 18:01:29
  • FYI this modification proposed on the ticket CC-5260 solved my problem for all files I could test.
    Post edited by Stephane Jourdan at 2013-07-09 17:59:40