Installation on Debian Wheezy
  • I've been having some issues installing, using both the easy install script and from source... dpkg also refuses to remove it, so whenever I do apt-get upgrade, it runs this: 

    :~# apt-get upgrade
    Reading package lists... Done
    Building dependency tree
    Reading state information... Done
    0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
    1 not fully installed or removed.
    After this operation, 0 B of additional disk space will be used.
    Do you want to continue [Y/n]? y
    Setting up airtime-easy-setup (2.3.0-1) ...
    Installing Sourcefabric package signing key...
    Setting up Airtime for America/New_York timezone...
    Setting Icecast and Airtime domain names to
    Setting defaults for non-interactive installation...
    Checking that the server has a UTF-8 locale...

    and just hangs at the last part. 

    I've been having some issues with locales sticking, they seem to reset to POSIX. 

    I need to basically start the installation over but dpkg isn't letting me remove it. 

    Where should I go from here?

  • 5 Comments sorted by
  • I had a lot of issues installing 2.3.1 on Debian Wheezy but managed to get it working. When I tried installing 2.4 I had the same issue. To uninstall I did the following: "apt-get --purge remove airtime". Reinstall and see.

    With 2.3.1 the issues were totally different. Get the 2.3.1 version and try that.
    Post edited by Reaz Baksh at 2013-05-24 08:57:11
  • Fixed it... had to set the locales and uninstall and reinstall. When I upload a song it doesn't seem to be added to the library for some reason though :/
  • Had that problem also. Make sure rabbitmq-server is running.  Run this: airtime-log -t and check to see if the rabbit is running.
  • I'm going to have to reinstall... my upgrade from squeeze -> wheezy broke other things, and I'm too lazy to fix them, so I'm going to configure everything from scratch and see if things begin to work. 
  • Update: it was a permissions issue. chmod 777 for the upload folder fixed it. 
    Post edited by Nolan Wagner at 2013-05-25 19:29:25