Can't install Airtime on Ubuntu Quantal server
  • Trying to install Airtime on a PPC Minimac server, currently Ubuntu Quantal server but also had similar problems on Debian Squeeze - here I've downloaded the .deb package and caled sudo gdebi airtime-easy-setup.deb in the correct directory:

    Reading package lists... Done
    Building dependency tree        
    Reading state information... Done
    Building data structures... Done 
    Building data structures... Done 

    Metapackage for the Airtime broadcast server
     This metapackage installs the dependencies for the Airtime broadcast
     automation system, and sets up a typical server configuration. For a
     multi-server install, you may prefer to install the airtime and
     icecast2 packages separately.
    Do you want to install the software package? [y/N]:y
    (Reading database ... 82038 files and directories currently installed.)
    Preparing to replace airtime-easy-setup 2.2.1-1 (using airtime-easy-setup.deb) ...
    Unpacking replacement airtime-easy-setup ...
    Setting up airtime-easy-setup (2.2.1-1) ...
    Installing Sourcefabric package signing key...
    Setting up Airtime for Etc/UTC timezone...
    Setting Icecast and Airtime domain names to ubuntu-minimac...
    Setting defaults for non-interactive installation...
    dpkg: error processing airtime-easy-setup (--install):
     subprocess installed post-installation script returned error exit status 1
    Errors were encountered while processing:

    I've followed the manual instructions and added the repositories, and checked for multiverse....when I try the apt-get install airtime I still get 'not found' - definitely connected as I've installed all the libraries etc. and downloaded Gdebi and the .deb file.

    Also complains about not having the public key, but if I try and add source fabric key:  sudo apt-get install sourcefabric-keyring it again says 'not found' - can I download and install this key manually without apt-get?

    Any ideas? Not a total Linux noob but not really an expert either...
    Post edited by Tim RadioClash at 2013-02-23 11:04:12
  • 6 Comments sorted by
  • EDIT: just found out that Airtime doesn't create binaries for PPC...this information might have been useful ON THE INSTALL PAGE OR MANUAL? Also - on Debian the PPC is a standard build so I assume that as the instructions mentioned Debian Squeezy they would support all flavours of it? Silly me.

    So, I'm compiling Liquidsoap - what about the rest - assume I have to compile Airtime from source? Help!
  • Compiled Liquidsoap - although it turns out it might have been there already. No idea how to compile or install Airtime from source. Some help here would be good? Looked everywhere and tried a few things I've found but it's all for older versions, like 2.1.4 - but no idea of how you install the thing.

    Post edited by Tim RadioClash at 2013-02-23 12:19:16
  • Ahh got it working with minimal install script...why did that work (even after making sure all the dependencies were there) and the full install fail? I did re-download it off the git repository, so don't know if that was a factor.

    Also - default user and password is admin/admin if anyone else is stuck on that (the minimal install didn't ask me to set a password or user). 

    Looked and looked in the manual for that info, unless I missed it? Ahh found it now but it just says 'and the password set during installation'
    Post edited by Tim RadioClash at 2013-02-23 13:27:01
  • Hi, 

    We will update our install page to indicate only x86/amd64 architectures are officially supported. Of course it's still possible to install Airtime on a PPC architecture, try installing liquidsoap from the apt repositories (sudo apt-get install liquidsoap), and then installing the Airtime debian package.

    If that doesn't work (haven't tried that in a long time), simply download the tarball of Airtime, and do the install_minimal. The reason the install_minimal works for you is because install_full handles installing all debian package dependencies, but it looks like that was taken care of when you unsuccessfully attempted installing the debian package.
    Airtime Pro Hosting:
  • Yes that's what I ended up doing, but made Liquidsoap from scratch, had real problems with the repositories - not sure I tried liquidsoap but all the others failed. Then installed from minimal and did the setup.

    Seems to be running fine, apart from mp3gain & apache spikes which I've used cpulimit to control (allowing pypo but limiting others) - this is partly the fact the server is a little underpowered (512Mb, 1.4Ghz PPC) but it is dedicated to this...I assume that's Airtime analysing the library? Not many tracks - 260 odd - but they are long complete shows, so I guess it's taking a time to analyse them?
  • Yea exactly. There's also a cue in/out analysis which automatically sets these points on your track to eliminate dead air. This is done automatically on import however as opposed to ReplayGain analysis which runs in quietly in the background.
    Airtime Pro Hosting: