SOLVED : newscoop 4.0.2 install blank page
  • I just downloaded the newscoop 4.0.2 and I tried to make a clean install. 

    Using xampp 1.7.3 i created a new folder under c:\xampps\htdocs and I uncompressed the tar file inside this folder.

    Using chrome I tried http://localhost/newscoop402 and it redirected me to /install subfolder with a blank white page.

    What's wrong here ? I even tried to create a new vhost like the following

    <VirtualHost newscoop402:80>
        DocumentRoot "C:/xampp/htdocs/newscoop402"
        ServerName newscoop402
        ServerAlias www.newscoop402.localhost
        DirectoryIndex index.php
        <Directory "C:/xampp/htdocs/newscoop402">
                Options -Indexes FollowSymLinks MultiViews
                AllowOverride All
                Order allow,deny
                Allow from all

    It does not worked either. Any recommendations ?

    Post edited by sdancer75 at 2012-11-06 02:13:54
  • 6 Comments sorted by
  • Vote Up0Vote Down Andrey PodshivalovAndrey Podshivalov
    Posts: 1,526Member, Administrator, Sourcefabric Team
    windows is not recommended for newscoop installing. Use some linux based os under virtualbox.
  • It worked just fine until now. Even the previous version worked fine. Now I can not even install.
  • It seems install, can not find the file


    at the CampTemplate.php
  • SOLVED  : Since campsite 3.5, I use this software and I am very pleased with your efforts and the quality of the platform, BUT  I had awlays search to find and correct stupid bugs.

    So, I could not continue the installation (clean and new, and just downloaded for sourceforge) because of that bug :

    In the CampTemplate.php under the /install/classes/CampTemplate.php

    at the beggining you have the 


    but it sould changed to 


    Post edited by sdancer75 at 2012-11-06 02:24:14
  • Reply to @sdancer75: It just works! Thanks :) ! How about PEAR under XAMPP ? How could you "enable" it under Windows?

    Many Thanks
  • I got it :) ! The problem was "as expected" the Windows-Path-Dilemma. I can understand @Andrey+Podshivalov saying "windows is not recommanded"  :) !

    To get PEAR working under XAMPP, just look into php.ini for: include_path , and check whether the assigned path has a drive letter, if so remove it. It must look like this:

    include_path = ".;\xampp\php\PEAR"

    AND NOT something like:

    include_path = ".;C:\xampp\php\PEAR"