Endless stuttering ALSA frame with liquidsoap
  • I've got an Airtime 2.1.2 installation, on Ubuntu 10.04.

    Several times a day, the audio output gets caught in an endless loop, stuttering the same 40ms frame of audio endlessly, over and over again, like a CD skipping.

    This is with an hda-intel soundcard, using ALSA output. There are no icecast streams, just audio card output. CPU usage is trivial during the times when this happens, like 3% or so.

    I should also note, that when this is happening, there's nothing odd in the airtime logs, no underruns, and nothing in /var/log/messages either. There seems to be no way to tell remotely that there's a problem, except you sure can hear it if you're there!

    Restarting the playout engine "solves" the problem. But then it chokes again some 5-10 hours later. This is obviously unacceptable for an unattended station.

    What is going on? How can I stop it from doing this?
    Post edited by muhoo at 2012-10-22 22:04:27
  • 5 Comments sorted by
  • Have you tried using the AO output option? This appears to be the most reliable sound API. Also I'd recommend you upgrade to 2.1.3 since it fixes several other playback issues.
    Airtime Pro Hosting: http://airtime.pro
  • The documentation recommended the ALSA driver. Is this no longer correct?

    Was this specific error addressed in 2.1.3? I don't recall seeing it in the changelog.

    I would like to specifically know what the cause is, what the solution is, and what the fix is. Randomly upgrading in hopes it'll fix things, doesn't work too well on a remote machine. Also randomly trying different drivers, doesn't really help either.

    If I tried something (like changing from ALSA to AO) and it "fixed" it, without knowing why or how, or what other problems that might introduce, then it wasn't really a fix, it was just superstition.
    Post edited by muhoo at 2012-10-24 20:08:12
  • The reason we give our users a choice of drivers is because some cards aren't fully supported by ALSA for example, and using another driver usually works. On my machine AO works much better than ALSA and it's a simple drop down menu change :)

    If you'd really like to use ALSA you could try swapping sound cards but there isn't much of an advantage in doing so.
    Airtime Pro Hosting: http://airtime.pro
  • Tried AO, same problem.

    That doesn't make any sense, since, libao uses.... ALSA as its back-end! It's just another layer in between ALSA (or OSS, or some others) and an audio application.

    In this case it's an hda-intel card, well-supported on ALSA anyway. Unsurprisingly, switching to AO made no difference, still get the endless stuttering.

    I'm going to have to try switching out sound cards now.
  • Does this looping happen randomly, or just for some subset of tracks? I don't think we've seen this problem before.
    Airtime Pro Hosting: http://airtime.pro