× Warning! This forum is in archival status. New contributions may not work.
[RESOLVED] Err : certains paquets ne peuvent être installés !
  • Hello,

    J'installe Airtime sur Ubuntu Precise 12.04 (Automated Installation)
    J'ai résolu mon précédent problème : nom d'hôte pour Icecast et Airtime (adresse IP de mon remote VPS)

    Pourtant le message ci-dessous s'affiche dans mon terminal quand je lance la commande :
    sudo apt-get install airtime

    ***********************
    Lecture des listes de paquets... Fait
    Construction de l'arbre des dépendances       
    Lecture des informations d'état... Fait
    Certains paquets ne peuvent être installés. Ceci peut signifier
    que vous avez demandé l'impossible, ou bien, si vous utilisez
    la distribution unstable, que certains paquets n'ont pas encore
    été créés ou ne sont pas sortis d'Incoming.
    L'information suivante devrait vous aider à résoudre la situation : 

    Les paquets suivants contiennent des dépendances non satisfaites :
     airtime : Dépend: liquidsoap (>= 1.0.0~) mais ne sera pas installé
    E: Impossible de corriger les problèmes, des paquets défectueux sont en mode « garder en l'état ».

    **************************
    Peut-être est-ce parce-que je dois rajouter “http://" devant l'adresse IP que j'utilise comme nom d'hôte ?

    Quelqu'un peut il m'aider svp ?


    Post edited by Clovis Hudson at 2012-09-19 03:23:04
  • 20 Comments sorted by
  • Vote Up0Vote Down Albert FRAlbert FR
    Posts: 1,978Member, Airtime Moderator
    pourtant je te l'ai déjà dis dans un tread en anglais ;-)

    mets dans ton sources.list le depot de sourcefabric et le problème sera resolu
  • Désolé Albert, il semble que j'ai zappé cette info.
    Cependant, je ne comprends pas comment faire ce que tu me dis, sauf peut-être si ça veut dire de lancer cette commande : sudo dpkg-reconfigure airtime

    Si ça n'est pas ça, alors où et sous quelle forme (ex : texte à copier) vais-je trouver le "dépôt sourcefabric" pour le mettre (coller ou ?) dans mon sources.list ?

    Merci
  • Vote Up0Vote Down Albert FRAlbert FR
    Posts: 1,978Member, Airtime Moderator
    edites ton sources.list :

      deb http://apt.sourcefabric.org/ precise main

    apt-get update
    apt-get update
    apt-get install sourcefabric-keyring
    apt-get dist-upgrade

    et au cas ou, mais normalement non

    apt-get install airtime

    Post edited by Albert FR at 2012-09-18 16:08:55
  • Err :

    apt-get install dist-upgrade
    Lecture des listes de paquets... Fait
    Construction de l'arbre des dépendances       
    Lecture des informations d'état... Fait
    E: Impossible de trouver le paquet dist-upgrade
  • Et finalement toujours la même erreur qu'au dédit de ce thread

    Les paquets suivants contiennent des dépendances non satisfaites :
     airtime : Dépend: liquidsoap (>= 1.0.0~) mais ne sera pas installé
    E: Impossible de corriger les problèmes, des paquets défectueux sont en mode « garder en l'état ».

  • Vote Up0Vote Down Albert FRAlbert FR
    Posts: 1,978Member, Airtime Moderator
    ooops :

    apt-get dist-upgrade

    au pire sinon tu fais un

    apt-get remove liquidsoap
    apt-get install liquidsoap

    il ne devrait plus te prendre celui de la distrib mais celui de sourcefabric
  • J'ai tous repris à 0

    (à la fin de sources.list)

    ET PUIS
    apt-get update
    apt-get update
    apt-get install sourcefabric-keyring (déjà installé)
    apt-get install dist-upgrade

    ERR :
    apt-get install dist-upgrade
    Lecture des listes de paquets... Fait
    Construction de l'arbre des dépendances       
    Lecture des informations d'état... Fait
    E: Impossible de trouver le paquet dist-upgrade



  • Vote Up0Vote Down Albert FRAlbert FR
    Posts: 1,978Member, Airtime Moderator
    ma faute, j'ai tapé trop vite :(

    apt-get dist-upgrade

  • Un fenêtre avec le titre "Configuration de grub-pc“ qui vient de s'ouvrir.
    Dedans on me demande de choisir entre 2 périphériques pour installer GRUB :

    /dev/sda (53687 Mo; Virtual_disk)
    /dev/sda1 (51532 Mo; Virtual_disk)

    Lequel choisir ?
  • Vote Up0Vote Down Albert FRAlbert FR
    Posts: 1,978Member, Airtime Moderator
    mdr,

    ben avec cette fonction ta distrib se met à jour :D

    le premier ;-)
  • J'ai placé le curseur au niveau du premier et fait OK, mais ça n'a pas été pris en compte.
    Quelle touche clavier dois-je taper pour sélectionner avant de valider ?

    J'ai essayer "o" pour oui mais ça fonctionne pas (rien ne s'affiche), pfff....

  • Vote Up0Vote Down Albert FRAlbert FR
    Posts: 1,978Member, Airtime Moderator
    essayes 1

    ou deplaces toi avec les fleches haut et bas, selectionne le premier et appuis sur entrée
    Post edited by Albert FR at 2012-09-18 16:58:59
  • J'ai tenté les 2 solutions !
    Mais quand je fais ok une nouvelle fenêtre m'explique que j'ai choisi d'installer grub sur aucun périphérique, et me propose de poursuivre, ou de revenir en arrière.

    J'essaie de trouver la solution....
  • Vote Up0Vote Down Albert FRAlbert FR
    Posts: 1,978Member, Airtime Moderator
    tapes :

     /dev/sda
  • Vote Up0Vote Down Albert FRAlbert FR
    Posts: 1,978Member, Airtime Moderator
    ah ah
    normalement il ne devrait pas te le demander, mais si il te le demande (ce qui est le cas) voici la doc de grub-pc : http://doc.ubuntu-fr.org/grub-pc

    Note : A un moment donné, vous devrez préciser dans quel disque
    dur GRUB 2 doit être installé (celui où est installé Ubuntu). À l'aide
    de la barre d'espacement du clavier, cochez ou décochez le disque dur
    concerné. Ne zappez pas cette étape, elle est obligatoire même si vous n'avez qu'un disque dur sinon vous risquez une Error 15 au redémarrage.

    Post edited by Albert FR at 2012-09-18 17:41:21
  • Ca a marché avec la barre d'espace qui a affiché (*)

    Et Youpi ! 

    -- Your installation of Airtime looks OK!

    ******************************* Install Complete *******************************
    Paramétrage de odbcinst (2.2.14p2-5ubuntu3) ...
    Traitement des actions différées (« triggers ») pour « libc-bin »...
    ldconfig deferred processing now taking place

    Cordialement

    Frantz
  • Vote Up0Vote Down Albert FRAlbert FR
    Posts: 1,978Member, Airtime Moderator
    cool :D

    bonne continuation à toi ;)
    bon moi je suis épuisé, je vais me coucher :D
    ( ça m’évitera de dire trop de bêtises sur ce forum :D
  • Bonjour!
     AIDE MOI SVP!!!!!!

    Les paquets suivants contiennent des dépendances non satisfaites :
     nfs-common : Dépend: libgssglue1 mais il n'est pas installable
                  Dépend: libnfsidmap2 mais il n'est pas installable
                  Dépend: libtirpc1 mais il n'est pas installable
                  Dépend: rpcbind (>= 0.2.0-6ubuntu1) mais ne sera pas installé
    E: Impossible de corriger les problèmes, des paquets défectueux sont en mode « garder en l'état ».

  • W: Impossible de récupérer http://mg.archive.ubuntu.com/ubuntu/dists/trusty/Release  Impossible de trouver l'entrée « restricted/source/Sources » attendue dans le fichier « Release » :  ligne non valable dans sources.list ou fichier corrompu

    E: Le téléchargement de quelques fichiers d'index a échoué, ils ont été ignorés, ou les anciens ont été utilisés à la place.