Can't install Newscoop on OSX with MAMP
  • I am trying to install Newscoop on a MacOSX via Mamp, but I always get
    this error:

    Error ID:2048:Newscoop:4.0.2:Section.php:24Error String:Declaration of
    Section::create() should be compatible with
    DatabaseObject::create($p_values = NULL)Time:Mon, 20 Aug 2012 21:22:54
    +0200Backtrace:

    Admin_Bootstrap::{closure}() called at
    [/Applications/MAMP/htdocs/classes/Section.php:24]
    require_once() called at [/Applications/MAMP/htdocs/classes/Issue.php:15]
    require_once() called at
    [/Applications/MAMP/htdocs/admin-files/init_content.php:3]
    require_once() called at
    [/Applications/MAMP/htdocs/application/modules/admin/Bootstrap.php:74]
    Admin_Bootstrap::_initNewscoop() called at
    [/Applications/MAMP/htdocs/library/Zend/Application/Bootstrap/BootstrapAbstract.php:667]
    Zend_Application_Bootstrap_BootstrapAbstract::_executeResource()
    called at [/Applications/MAMP/htdocs/library/Zend/Application/Bootstrap/BootstrapAbstract.php:620]
    Zend_Application_Bootstrap_BootstrapAbstract::_bootstrap() called at
    [/Applications/MAMP/htdocs/library/Zend/Application/Bootstrap/BootstrapAbstract.php:584]
    Zend_Application_Bootstrap_BootstrapAbstract::bootstrap() called at
    [/Applications/MAMP/htdocs/library/Zend/Application/Resource/Modules.php:107]
    Zend_Application_Resource_Modules::init() called at
    [/Applications/MAMP/htdocs/library/Zend/Application/Bootstrap/BootstrapAbstract.php:681]
    Zend_Application_Bootstrap_BootstrapAbstract::_executeResource()
    called at [/Applications/MAMP/htdocs/library/Zend/Application/Bootstrap/BootstrapAbstract.php:624]
    Zend_Application_Bootstrap_BootstrapAbstract::_bootstrap() called at
    [/Applications/MAMP/htdocs/library/Zend/Application/Bootstrap/BootstrapAbstract.php:584]
    Zend_Application_Bootstrap_BootstrapAbstract::bootstrap() called at
    [/Applications/MAMP/htdocs/library/Zend/Application.php:355]
    Zend_Application::bootstrap() called at
    [/Applications/MAMP/htdocs/public/index.php:4]
    require_once() called at [/Applications/MAMP/htdocs/admin.php:4]


    I already reinstalled Mamp, but I keep getting this bug; what should I do?

    Thank you

    ---  answer ----------

    This looks like an issue with PHP 5.4.  Edit your php.ini, usually in /Applications/MAMP/bin/php/.  With a default install of the latest version of MAMP (2.1.1) and latest packaged PHP (5.4.4), your php.ini would be here: /Applications/MAMP/bin/php/php5.4.4/conf/php.ini.

    Edit this line:

    error_reporting = E_ALL & ~E_DEPRECATED

    to

    error_reporting = E_ALL & ~E_DEPRECATED & ~E_NOTICE & ~E_STRICT

    save the file, and then stop and start servers in MAMP.  Should resolve the issue for you.


    -mark

  • 4 Comments sorted by
  • Is there anything else that should be done to a default installation of Newscoop and MAMP to rectify the problem? I've re-installed both multiple times and edited the error_reporting line as mentioned; still no luck!
  • Same here ! 

    The error ID says 

    2048:Newscoop:4.0.2:Issue.php:1122

    Here's the line 1122
    } // class Issue


  • I had Error ID: 2048:Newscoop:4.4.7:SaaS.php:20 creating new article. But that was long ago. I then had to upgrade the php version to 5.6.25: https://github.com/sourcefabric/Newscoop/issues/1404


    Post edited by Stefan Albrecht at 2019-08-28 05:41:57
  • Yes i have also been facing this issue since last week ..Hopeful of an accurate solution soon mypascoconnect
    Post edited by Steven30 at 2019-09-10 02:42:06