× Warning! This forum is in archival status. New contributions may not work.
Newscoop 4 Installation error
  • Hello,

    I would like to install  but i have this error.

    Warning: require_once(__DIR__/../application.php) [function.require-once]: failed to open stream: No such file or directory in /home/cooeo/public_html/install/index.php on line 16

    Fatal error: require_once() [function.require]: Failed opening required '__DIR__/../application.php' (include_path='.:/usr/lib/php:/usr/local/lib/php') in /home/cooeo/public_html/install/index.php on line 16
  • 39 Comments sorted by
  • Vote Up0Vote Down Jakub GórnickiJakub Górnicki
    Posts: 134Member, Administrator, Sourcefabric Team
    Are you running this on your own server? Have you installed Newscoop there before?
  • Vote Up0Vote Down Daniel JamesDaniel James
    Posts: 844Member, Sourcefabric Team
    Hi George, is this a shared hosting server by any chance? If not, which GNU/Linux distribution is it running?

    Cheers!

    Daniel
  • Vote Up0Vote Down gustavogustavo
    Posts: 27Member
    Hola, la verdad instale Newscoop 3.5.3 sin problemas, pero como hago para actualizar a Newscoop 4? la verdad intente sobreescribir la instalacion vieja con la version 4 y me sale:


    Warning: Unexpected character in input: '\' (ASCII=92) state=1 in /home/apmnotic/public_html/prueba/application.php on line 65



    Parse error: syntax error, unexpected T_FUNCTION in /home/apmnotic/public_html/prueba/application.php on line 68
  • Vote Up0Vote Down Andrey PodshivalovAndrey Podshivalov
    Posts: 1,526Member, Administrator, Sourcefabric Team
    newscoop 4.0 requires php 5.3
  • Vote Up0Vote Down gustavogustavo
    Posts: 27Member
    Hola, despues de mis consultas ibumu.com me respondio lo siguiente:



    Que tal Gustavo. Agregamos en el archivo .htaccess la sentencia para que

    el script trabaje sobre php 5.3. Pero el sitio ahora arroja un error y

    vemos en el archivo error_log, lo siguiente:


    [14-May-2012 23:03:02 UTC] PHP Fatal error: require_once() [<a href='function.require'>function.require</a>]: Failed opening required 'smarty/libs/Smarty.class.php' (include_path='/home/apmnotic/public_html/prueba2012/classes:/home/apmnotic/public_html/prueba2012/classes/Extension:/home/apmnotic/public_html/prueba2012/template_engine/classes:/home/apmnotic/public_html/prueba2012/template_engine/metaclasses:/home/apmnotic/public_html/prueba2012/application/../library:/home/apmnotic/public_html/prueba2012/library:/home/apmnotic/public_html/prueba2012/include:.:/opt/php53/lib/php') in /home/apmnotic/public_html/prueba2012/install/classes/CampTemplate.php on line 13  






    Desafortunadamente el script requiere extensiones

    extra para php que no están instaladas en el servidor. Es por eso que no

    funciona y no se podrá hacer la instalación.


    Tal

    vez el desarrollador del script le brinde algún tipo de soporte u

    opciones para este tipo de casos. Tendría que ponerse en contacto con

    ellos.
  • Vote Up0Vote Down Andrey PodshivalovAndrey Podshivalov
    Posts: 1,526Member, Administrator, Sourcefabric Team
    restore files from newscoop tarball on linux machine instead of on windows
  • Vote Up0Vote Down gustavogustavo
    Posts: 27Member
    Hola, yo instalo newscoop4 en mi cuenta en ibumu.com via cpanel. Copio el zip de newscoop y lo descomprimo en prueba2012.apmnoticias.com. Mi pc usa windows xp. le tengo que pasar newscoop.zip a los administradores de ibumu.com para que ellos me instalen en mi localhost?
  • Vote Up0Vote Down Andrey PodshivalovAndrey Podshivalov
    Posts: 1,526Member, Administrator, Sourcefabric Team
    open for edit file /home/apmnotic/public_html/prueba2012/install/classes/CampTemplate.php and change 'smarty/libs/Smarty.class.php' to  'smarty/Smarty.class.php'  (string #13)
  • Vote Up0Vote Down gustavogustavo
    Posts: 27Member
    funciono, me permitio determinar la base de datos y luego al continuar:
    Warning: Unexpected character in input: '\' (ASCII=92) state=1 in /home/apmnotic/public_html/prueba2012/application.php on line 65

    Parse error: syntax error, unexpected T_FUNCTION in /home/apmnotic/public_html/prueba2012/application.php on line 68
  • Vote Up0Vote Down gustavogustavo
    Posts: 27Member
    Si, reclamare a la gente de ibumu.com, por que ellos me dijeron que todo estaba solucionado y mi php era  5.3
  • Vote Up0Vote Down Andrey PodshivalovAndrey Podshivalov
    Posts: 1,526Member, Administrator, Sourcefabric Team
    place on hosting the file test.php with content:
    <? phpinfo(); ?> and invoke it via browser. It will show all php settings.
  • Vote Up0Vote Down gustavogustavo
    Posts: 27Member
    podrias ser mas claro?
  • Vote Up0Vote Down gustavogustavo
    Posts: 27Member
    o mejor explicarme mas detalladamente? soy novato con algun conocimiento. Gracias
  • Vote Up0Vote Down gustavogustavo
    Posts: 27Member
    bueno ya pude, leer un poco e intentar. gracias
    http://prueba2012.apmnoticias.com.ar/test.php
    Post edited by gustavo at 2012-05-16 14:37:48
  • Vote Up0Vote Down Andrey PodshivalovAndrey Podshivalov
    Posts: 1,526Member, Administrator, Sourcefabric Team
    good, but not good news.
    as you can see hosting has installed PHP Version 5.2.17. Newscoop requires 5.3.x
  • Vote Up0Vote Down gustavogustavo
    Posts: 27Member
    En estos momentos estoy haciendo el reclamo. Cualquier novedad te cuento. Mil Gracias.
  • Vote Up0Vote Down gustavogustavo
    Posts: 27Member
    Hola, esta es la respuesta de ibumu.com:


    "Que tal Gustavo. Para que el script funcione bajo php 5.3 debe tener un archivo .htaccess con la siguiente sentencia:

    # Use PHP 5.3
    AddType application/x-httpd-php53 .php



    Veo que el archivo está renombrado como .htaccess-default, es por
    esto que no se está tomando la versión 5.3. Por otro lado veo que el
    error que le muestra el sistema tiene que ver con un caracter ascii, que
    no tiene que ver con la versión de php.



    Revise la documentación del script al respecto.

    Cualquier otra duda nos indica.
    Saludos
    Federico M."
  • Vote Up0Vote Down Andrey PodshivalovAndrey Podshivalov
    Posts: 1,526Member, Administrator, Sourcefabric Team
    add in .htaccess file the string:

    AddType application/x-httpd-php53 .php


  • Vote Up0Vote Down gustavogustavo
    Posts: 27Member
    Tiene que quedar asi? (.htaccess file)


    # There might be no access to apache config, set options here
    DirectoryIndex index.php index.html
    Options -Indexes FollowSymLinks -MultiViews

    AddType video/ogg .ogm
    AddType video/ogg .ogv
    AddType audio/ogg .ogg
    AddType video/mp4 .mp4
    AddType video/webm .webm

    # Options might not allowed here, use Rewrite rules instead
    <IfModule mod_rewrite.c>
        RewriteEngine On

        RewriteCond %{REQUEST_URI} /+get_img$
        RewriteRule . get_img.php [L]

        RewriteCond %{REQUEST_URI} /+attachment/+
        RewriteRule . attachment.php [L]

        RewriteCond %{REQUEST_URI} /+images/+cache
        RewriteCond %{REQUEST_FILENAME} !-f
        RewriteRule . index.php [L]

        RewriteCond %{REQUEST_URI} !\.php$
        RewriteCond %{REQUEST_URI} !\.html$
        RewriteCond %{REQUEST_URI} !\.css$
        RewriteCond %{REQUEST_URI} !\.js$
        RewriteCond %{REQUEST_URI} !\.ico$
        RewriteCond %{REQUEST_URI} !/+admin
        RewriteCond %{REQUEST_URI} !/+install
        RewriteCond %{REQUEST_URI} !(/+plugins/[^/]*)?/+js
        RewriteCond %{REQUEST_URI} !(/+plugins/[^/]*)?/+css
        RewriteCond %{REQUEST_URI} !(/+plugins/[^/]*)?/+images
        RewriteCond %{REQUEST_URI} !/+themes
        RewriteCond %{REQUEST_URI} !/+videos
        RewriteCond %{REQUEST_URI} !/+pdf
        RewriteCond %{REQUEST_URI} !/+images/+cache
        RewriteRule . index.php [L]

        RewriteCond %{REQUEST_URI} .tpl$
        RewriteRule . index.php [L]

        RewriteCond %{REQUEST_URI} /+admin$|/+admin/+.*|/+admin-files
        RewriteRule . admin.php [L]
    </IfModule>

    # Uncomment it for gui backup/restore process
    # NOTE: It can be incompatible on some shared hosting
    #php_value output_buffering Off
    # Use PHP 5.3
    AddType application/x-httpd-php53 .php
  • Vote Up0Vote Down Andrey PodshivalovAndrey Podshivalov
    Posts: 1,526Member, Administrator, Sourcefabric Team
    right
  • Vote Up0Vote Down gustavogustavo
    Posts: 27Member
    mmmmmmmmmmmmmmmm me sigue dando el mismo error:

    Warning: Unexpected character in input: '\' (ASCII=92) state=1 in /home/apmnotic/public_html/prueba2012/application.php on line 65

    Parse error: syntax error, unexpected T_FUNCTION in /home/apmnotic/public_html/prueba2012/application.php on line 68

    los de ibumu.com se cierran en que "
    el error que le muestra el sistema tiene que ver con un caracter ascii, que
    no tiene que ver con la versión de php.". helpppppppppppppppp
  • Vote Up0Vote Down Andrey PodshivalovAndrey Podshivalov
    Posts: 1,526Member, Administrator, Sourcefabric Team
    ask hoster support for help. http://prueba2012.apmnoticias.com.ar/test.php reports about php 5.2.17


  • Vote Up0Vote Down gustavogustavo
    Posts: 27Member
    Mira recien probe con:

    ###### ApacheFriends XAMPP version 1.7.7 ######

      + Apache 2.2.21
      + MySQL 5.5.16 (Community Server)
      + PHP 5.3.8 (VC9 X86 32bit thread safe) + PEAR
      + XAMPP Control Panel Version 2.5 from www.nat32.com
      + (BETA) XAMPP Control Panel Version 3.0.2 by Steffen Strueber (not in the USB & lite version)
        see http://www.apachefriends.org/f/viewtopic.php?f=16&t=46743
      + XAMPP Security
      + OpenSSL 1.0.0e
      + phpMyAdmin 3.4.5
      + ADOdb 5.14
      + Mercury Mail Transport System v4.62 (not in the USB & lite version)
      + FileZilla FTP Server 0.9.39 (not in the USB & lite version)
      + Webalizer 2.23-04 (not in the USB & lite version)
      + Perl 5.10.1 (not in the USB & lite version)
      + Mod_perl 2.0.4 (not in the USB & lite version)
      + Tomcat 7.0.21 (not in the USB & lite version)

    anda de 10. la verdad no se que hacer. Los de Ibumu.com, no quieren poner php 5.3.
  • Buenas tardes:

     Soy nuevo en newscoop, anteriormente habia trabajado con otros cms como xoops, phpbb, etc, epro he decidido montar un periodico online y me he decantado por este CMS, el cual me da muy buena impresión, pero tengo un problema, he subido todos los archivos "120 megas" al servidor a la carpeta "public html" pero cuando intento abrir la web me aparece este error:

    Warning: Unexpected character in input: '\' (ASCII=92) state=1 in /home/todopre/public_html/application.php on line 65



    Parse error: syntax error, unexpected T_FUNCTION in /home/todopre/public_html/application.php on line 68

    Por lo que he podido entender en los foros "mi ingles es cortito" el fallo puede ser porque el servidor no tenga PHP 5.3 ¿es cierto esto? ¿puede ser por otra causa el error?.

    Muchas gracias por vuestra ayuda.
  • Vote Up0Vote Down gustavogustavo
    Posts: 27Member
    Hola, si seguis el hilo de la charla con el amigo Andrey Podshivalov, veras que desde hace rato trato de instalar newscoop4. Son muy ciertos todos los cambios que el indica, recien los muchachos de ibumu.com modificaron por mi el archivo .htaccess y segun ellos funciona todo. Aun no puedo ver prueba2012.apmnoticias.com.ar por que no tengo acceso (se me corta internet).  Apenas se reestablezca la comunicacion con la web alojada en ibumu.com podre ver si es verdad lo que ellos dicen. y de paso realizar un manual en español de como instalarlo y no morir en el intento. Estare en contacto. Saludos desde San pedro de Jujuy Argentina
  • Muchas gracias Gustavo, espero a ver que comentas sobre la instalación. Y si necesitas algun tipo de ayuda solo tienes que decirlo.

    Un saludo desde Sevilla España.


  • Vote Up0Vote Down gustavogustavo
    Posts: 27Member
    Ahora logre ingresar a las primeras tres pantallas de la instalacion pero donde pongo los datos de la base de datos me sale:



    Error: Importing Database
    CREATE TABLE IF NOT EXISTS `user_identity` (
    `provider` varchar(80) NOT NULL,
    `provider_user_id` varchar(255) NOT NULL,
    `user_id` int(11) unsigned NOT NULL,
    PRIMARY KEY (`provider`, `provider_user_id`)
    ) ENGINE=InnoDB DEFAULT CHARSET=utf8


    los datos que ingreso nombre, usuario y pass, son correctos y si nuevamente ingreso los datos sale el cartel:


    Warning: require_once(__DIR__/../application.php) [function.require-once]: failed to open stream: No such file or directory in /home/apmnotic/public_html/prueba2012/install/index.php on line 16



    Fatal error: require_once() [function.require]: Failed opening required '__DIR__/../application.php' (include_path='.:/usr/lib/php:/usr/local/lib/php') in /home/apmnotic/public_html/prueba2012/install/index.php on line 16


  • Vote Up0Vote Down Andrey PodshivalovAndrey Podshivalov
    Posts: 1,526Member, Administrator, Sourcefabric Team
    ok, could you try to execute sql command via phpmyadmin?
    Try this command:

    CREATE TABLE IF NOT EXISTS `user_identity` (

    `provider` varchar(80) NOT NULL,

    `provider_user_id` varchar(255) NOT NULL,

    `user_id` int(11) unsigned NOT NULL,

    PRIMARY KEY (`provider`, `provider_user_id`)

    ) ENGINE=InnoDB DEFAULT CHARSET=utf8

    please report about result
  • Vote Up0Vote Down gustavogustavo
    Posts: 27Member
    Bueno luego de luchar con la gente del hosting, logre que .htaccess este configurado correctamente para php 5.3. Lance la instalacion, ya no me salio el error anterios de la falta de una tabla en la bd. Fue todo por los carriles normales hasta que en la pantalla del administrador dice:

    Reporte de error ID del error: 2:Newscoop:4.0:Loader.php:146 String de error: include_once(doctrine/orm/query/kqw9j.php) [function.include-once]: failed to open stream: No such file or directory Hora: Fri, 18 May 2012 11:16:55 -0500 Backtrace: {closure}() called at [/home/apmnotic/public_html/prueba2012/library/Zend/Loader.php:146]Zend_Loader::loadFile() called at [/home/apmnotic/public_html/prueba2012/library/Zend/Loader.php:146]Zend_Loader::loadFile() called at [/home/apmnotic/public_html/prueba2012/library/Zend/Loader.php:94]Zend_Loader::loadClass() called at [:]call_user_func() called at [/home/apmnotic/public_html/prueba2012/library/Zend/Loader/Autoloader.php:472]Zend_Loader_Autoloader::_autoload() called at [:]call_user_func() called at [/home/apmnotic/public_html/prueba2012/library/Zend/Loader/Autoloader.php:124]Zend_Loader_Autoloader::autoload() called at [:]spl_autoload_call() called at [:]defined() called at [/home/apmnotic/public_html/prueba2012/library/Doctrine/ORM/Query/Lexer.php:161]Doctrine\ORM\Query\Lexer::getType() called at [/home/apmnotic/public_html/prueba2012/library/Doctrine/Common/Lexer.php:214]Doctrine\Common\Lexer::scan() called at [/home/apmnotic/public_html/prueba2012/library/Doctrine/Common/Lexer.php:70]Doctrine\Common\Lexer::setInput() called at [/home/apmnotic/public_html/prueba2012/library/Doctrine/ORM/Query/Lexer.php:117]Doctrine\ORM\Query\Lexer::__construct() called at [/home/apmnotic/public_html/prueba2012/library/Doctrine/ORM/Query/Parser.php:145]Doctrine\ORM\Query\Parser::__construct() called at [/home/apmnotic/public_html/prueba2012/library/Doctrine/ORM/Query.php:212]Doctrine\ORM\Query::_parse() called at [/home/apmnotic/public_html/prueba2012/library/Doctrine/ORM/Query.php:234]Doctrine\ORM\Query::_doExecute() called at [/home/apmnotic/public_html/prueba2012/library/Doctrine/ORM/AbstractQuery.php:607]Doctrine\ORM\AbstractQuery::execute() called at [/home/apmnotic/public_html/prueba2012/library/Doctrine/ORM/AbstractQuery.php:480]Doctrine\ORM\AbstractQuery::getSingleResult() called at [/home/apmnotic/public_html/prueba2012/library/Doctrine/ORM/AbstractQuery.php:506]Doctrine\ORM\AbstractQuery::getSingleScalarResult() called at [/home/apmnotic/public_html/prueba2012/library/Newscoop/Services/StatService.php:123]Newscoop\Services\StatService::getArticles() called at [/home/apmnotic/public_html/prueba2012/library/Newscoop/Services/StatService.php:45]Newscoop\Services\StatService::getAll() called at [/home/apmnotic/public_html/prueba2012/application/modules/admin/controllers/SupportController.php:49]Admin_SupportController::popupAction() called at [/home/apmnotic/public_html/prueba2012/library/Zend/Controller/Action.php:513]Zend_Controller_Action::dispatch() called at [/home/apmnotic/public_html/prueba2012/library/Zend/Controller/Dispatcher/Standard.php:295]Zend_Controller_Dispatcher_Standard::dispatch() called at [/home/apmnotic/public_html/prueba2012/library/Zend/Controller/Front.php:954]Zend_Controller_Front::dispatch() called at [/home/apmnotic/public_html/prueba2012/library/Zend/Application/Bootstrap/Bootstrap.php:97]Zend_Application_Bootstrap_Bootstrap::run() called at [/home/apmnotic/public_html/prueba2012/library/Zend/Application.php:366]Zend_Application::run() called at [/home/apmnotic/public_html/prueba2012/public/index.php:7]require_once() called at [/home/apmnotic/public_html/prueba2012/admin.php:4]


    Por favor tome un minuto para enviarnos un mensaje de correo.

    Solo copie y pegue el reporte de error abajo y envíelo a: newscoop-bug@sourcefabric.org.



    Gracias




    en http://prueba2012.apmnoticias.com.ar/ pueden verlo
    Post edited by gustavo at 2012-05-18 12:23:26
  • Vote Up0Vote Down Andrey PodshivalovAndrey Podshivalov
    Posts: 1,526Member, Administrator, Sourcefabric Team
    oh, it's know issue. It affect only some shared hosting that has installed some zend stuff.
    Well, I can suggest you to use some cheap vps solution instead of shared hosting.
    At least Amazon micro instance works fine with newscoop.
  • Vote Up0Vote Down gustavogustavo
    Posts: 27Member
    Bueno una lastima no poder usar newscoop en ibumu.com. Gracias por todo.
  • hi andrey

    i have this issue with my host - so waiting for a fix

    1 thing i did notice though in when you download the source file the Include > Smarty > libs folder appears as an alias on my mac 

    is that my mac or is their a reason for that
  • Vote Up0Vote Down Andrey PodshivalovAndrey Podshivalov
    Posts: 1,526Member, Administrator, Sourcefabric Team
    I don't recommend waiting for fix. Use vps hosting instead.

    Include>Smarty>libs should be as symlink. So, your mac shows correctly. Will be removed to avoid unnecessary issues especially on windows machine.
  • Vote Up0Vote Down gustavogustavo
    Posts: 27Member
    Hola, en estos momentos estoy probando en otro hosting y me sale:
    Warning: require_once(__DIR__/../application.php) [function.require-once]: failed to open stream: No such file or directory in /home/apmfotog/public_html/public/index.php on line 3



    Fatal error: require_once() [function.require]: Failed opening required '__DIR__/../application.php' (include_path='.:/usr/lib/php:/usr/local/lib/php') in /home/apmfotog/public_html/public/index.php on line 3
  • Vote Up0Vote Down gustavogustavo
    Posts: 27Member
    Hola, lo anterior ya lo solucionan cambiando a un servidor con php 5.3
  • Vote Up0Vote Down gustavogustavo
    Posts: 27Member
    Hola, lo anterior ya lo solucionan cambiando a un servidor con php 5.3
  • Vote Up0Vote Down gustavogustavo
    Posts: 27Member
    Hola ya tengo php 5.3, pero  me sale el siguiente mensaje:ç

    Warning: set_time_limit() [function.set-time-limit]: Cannot set time limit in safe mode in /home/apmfotog/public_html/install/index.php on line 13
  • Vote Up0Vote Down Andrey PodshivalovAndrey Podshivalov
    Posts: 1,526Member, Administrator, Sourcefabric Team

    gustavo said:

    Warning: set_time_limit() [function.set-time-limit]: Cannot set time limit in safe mode in /home/apmfotog/public_html/install/index.php on line 13



    Newscoop doesn't support php safe mode. Use any vps hosting instead of shared.