Upgrade from 1.8.2 to 2.0.1: filenames not preserved
  • Hi all,

    I have just completed the upgrade from 1.8.2 to 2.0.1 and noticed all the files in the database are now called 0f76b3df1a1d5cc5351673af1498a514-169kbps or something like that. Is this the expected behaviour? I would have hoped that the filenames would be preserved in the Playlist Builder after the upgrade as we now have a database of over 2000 files which are unidentifiable!


  • 12 Comments sorted by
  • I just tried a clean install of 1.8.2 on another test machine and recorded a short 5 minute show called "record test 1". Then upgraded to 2.0.1. The filename is preserved ok. So I assume that upgrading to 2.0.1 should preserve the filenames, even when they are recorded with 1.8.2 and are saved in the database with an unrecognisable filename.

    This doesn't happen on our main test machine (with which we hope to go live as soon as 2.0.x is stable). We have a large database of files which are symlinked from /srv/airtime like this:

    ~$ ls -l /srv/airtime
    lrwxrwxrwx 1 root root 19 2011-08-29 14:42 /srv/airtime -> /media/usb/airtime/

    Is it possible to preserve the filenames on upgrade?


  • Hi James,

    Can you please give a better description to how you set up the symlink?

    I'm trying to reproduce your error but I'm not really sure how it's set up.

  • Hi Ofir,

    Thanks for your reply. We have airtime 1.8.2 installed
    on our production machine which records around 8GB of audio files each
    week. Each file is around 86, 172 or 256mb for every 1, 2 or 3 hour
    show. This is too much data to store on the internal hard drive, so I
    created a symlink to a 2TB external USB hard drive as follows:

    sudo mkdir /media/usb/airtime
    cd /srv/airtime/
    sudo mv stor /media/usb/airtime/
    cd ../
    sudo rm -rf airtime
    sudo ln -s /media/usb/airtime/stor airtime

    has been working nicely for several months, and solves our space
    issues. The recorded shows are copied to /srv/airtime/stor (really
    /media/usb/airtime/stor). I have attempted several upgrades to 2.0.1. To
    do this, I made an rsync backup of /media/usb/airtime/stor and after
    installing 1.8.2 on the testing machine, I created a symlink to the new
    backup directory (media/usb/PC2/airtime/stor). The new PC works fine
    with this directory. After upgrading to 2.0.1 however, the filenames are
    not preserved in the database (the Playlist Builder in the web ui). For

    Some Show 2012-02-23-12:00:00



    I hope this is clear

  • Also, I just tried recording another show on a clean install of 1.8.2 and upgrading to 2.0.1 and the filename was preserved in the database. Then I tried another clean install of 1.8.2, changed the storage directory to a symlink, and made a recording of a show. Then upgraded to 2.0.1 and the filename was NOT preserved. So it must be something to do with the symlink...

  • Hi James,

    We are looking into this. Stay tuned.
    Airtime Pro Hosting: http://airtime.pro
  • I think your method of creating a symlink is wrong.

    Does it work when you do it this way?

    sudo mkdir /media/usb/airtime 
    cd /srv/airtime/
    sudo mv stor /media/usb/airtime/
    sudo ln -s /media/usb/airtime/stor stor
    Airtime Pro Hosting: http://airtime.pro
  • Unfortunately not. I did a fresh install of 1.8.2 on a test machine (Ubuntu 10.04.4 LTS), copied and pasted your commands and then recorded a 5 min show. After upgrading to 2.0.1, the filename was changed from:

    record test 1-2012-02-25-13:25:00



  • Hi James,

    This has been fixed for 2.0.2, we should be released this week.

    Airtime Pro Hosting: http://airtime.pro
  • Great, thanks!
  • Hi James,

    I'm still not sure about the exact scenario that you managed to symlink.

    I want to make sure your problem was addressed in version 2.0.2

    You can download our latest code from

    $ git clone git://github.com/sourcefabric/Airtime.git

    and then

    $ cd Airtime
    $ git checkout 2.0.x

    this holds the 2.0.2 code (under development)

    Please let me know your findings over the weekend.
  • Hi Ofir,

    Yes this seems to be working perfectly now.


  • That's great news James 
    Post edited by Ofir Gal at 2012-03-05 12:03:19
This discussion has been closed.
All Discussions