Upgrade to airtime 1.9.5 from 1.8.2 stalled....
  • On Wednesday afternoon I started a manual upgrade of Airtime 1.8.2 to 1.9.5 on our Ubuntu 10.04 server. We have a large database of 1,633 files totalling around 204GB. I attempted to upgrade via ssh and forgot to put the upgrade command in a screen, so had to restart it when the pipe broke whilst  the upgrade was reorganising files in the stor directory. I ran the upgrade command again and it resumed reorganising the files in the stor directory however it has now stalled at 1417 files...

    I know it has reorganised this many files because I am checking it periodically with:

    find /media/usb/PC2/airtime/stor/ -type f | egrep 'imported|organize|recorded' | wc -l


    find /media/usb/PC2/airtime/stor/ -type f | egrep -v 'imported|organize|recorded' | wc -l

    to see how many are left. It's been several hours since it last copied a file so I assume it's stuck - how can I complete the upgrade?

    I've attached the install log



  • 5 Comments sorted by
  • Ah I found a wav file in the database - could this be the problem? Every other file is an mp3. I manually deleted the wav from the hard drive although I can't delete it from the airtime web ui as the upgrade is still in progress and the web ui is not functional. Any other ideas?


  • Vote Up0Vote Down Albert FRAlbert FR
    Posts: 1,978Member, Airtime Moderator
    have you made an :
    airtime-db-update (or something like that, I haven't any computer to test that for the moment)

    in command line ?
  • Just tried that but it hasn't changed anything.. Can anyone help with this? Airtime is currently unusable as it has stalled in the upgrade between 1.8.2 and 1.95 and we really want to get this sorted ASAP.


  • Vote Up0Vote Down Paul BaranowskiPaul Baranowski
    Posts: 389Member, Administrator, Sourcefabric Team
    Hi James -
    Could you please send us your logs?  Just do:
    sudo airtime-log -d
    and attach the file that it produces.

    Did you backup the database before the upgrade?

    I know this advice comes too late, but you never ever want to upgrade a
    live server.  Always test on a staging server before you deploy live.  If you dont want to go through these headaches
    again you can sign up for Airtime Pro: http://airtime.pro ;)

    - Paul

  • Hi Paul,

    thanks for your reply. We do have a backup fortunately.

    $ sudo airtime-log -d
    sudo: airtime-log: command not found

    Probably because the upgrade didn't finish installing (it's somewhere between the two versions), the new airtime-log command doesn't exist.

    I've attached the logs from /var/log/airtime/