ProxyPass ProxyPassReverse Fail
  • Hi there,

    I have Airtime running at:

    but it needs to be served from

    Any ideas why ProxyPass and ProxyPassReverse don't work with Airtime?

    Despite below location code, Apache2 still ends up serving from


    instead of

    <Location /airtime>
    order deny,allow
    deny from all
    allow from all

    <VirtualHost *:8008>
          DocumentRoot /usr/share/airtime/public
          DirectoryIndex index.php
          SetEnv APPLICATION_ENV "production"
          <Directory /usr/share/airtime/public>
                  Options Indexes FollowSymLinks MultiViews
                  AllowOverride All
                  Order allow,deny
                  Allow from all
  • 2 Comments sorted by
  • Vote Up0Vote Down Andrey PodshivalovAndrey Podshivalov
    Posts: 1,526Member, Administrator, Sourcefabric Team
    there are two mistakes:
    - ProxyPass, ProxyPassReverse can not be applied for location but virtual host.
    - Airtime is not ready to be used under subfolder. So host/airtime won't work.
  • Hi Andrey,

    Not sure what you mean with mistakes...

    I have this type of proxy configured for 2 other servers (Sam Broadcaster and SABnzbdplus).
    They work just fine!

    What is it exactly that stops Airtime ?