× Warning! This forum is in archival status. New contributions may not work.
[Solved] On air button not working -> Streaming Silence
  • I really don't know how to do...

    I checked Timezone:
    - /etc/timezone ok
    - /etc/php5/apache2/php.ini ok
    - .htaccess ok

    Checked the api key in this method:

    http://forum.sourcefabric.org/index.php/mv/msg/3564/10562/#m sg_10562

    But it's ok... Sad

    I attached all my logs...
  • 16 Comments sorted by
  • Hi Andrea,

    This appears to be the culprit:
    Quote:
    @400000004dbab2e3160229b4 2011-04-29 14:45:13,368 WARNING - [pypofetch.py : handle_media_file() : line 246] - zero-size file - skipping /var/tmp/airtime/pypo/cache/scheduler/2011-04-29-14-46-00/86 7c8b0b6f3bf7a623b1bea030892559.mp3. will not add it to playlist



    Post what message you get when you visit this link in your browser:

    Quote:
    http://overadio.dyndns.org:80/api/get-media/file/867c8b0b6f3 bf7a623b1bea030892559.mp3/api_key/%%api_key%%


    Make sure you replace %%api_key%% with your private api_key.

    When it works, it should automatically start downloading the file. I suspect you are getting an error message instead.
    Airtime Pro Hosting: http://airtime.pro
  • No error, only a blank page Sad
  • That's probably because i changed the storage directory...

    I will try to uninstall airtime and then reinstall it, using a symbolinc link to redirect the storage to my home. Wich permissions should i use? (Owner/Group)
  • Vote Up0Vote Down Paul BaranowskiPaul Baranowski
    Posts: 389Member, Administrator, Sourcefabric Team
    You can tell airtime where your storage directory is in the config file:
    /etc/airtime/airtime.conf




    On Tue, May 3, 2011 at 4:51 AM, Andrea Giardini <
    airtime-support@lists.sourcefabric.org> wrote:

    > That's probably because i changed the storage directory...
    >
    > I will try to uninstall airtime and then reinstall it, using a symbolinc
    > link to redirect the storage to my home. Wich permissions should i use?
    > (Owner/Group)
    >

  • base_files_dir = /home/{username}/storage
    


    And that's "ls -l":

    drwxrwxrwx 2 root     www-data    4096 25 apr 22.56 storage
    


    Should I also chown to www-data?

    p.s. i'm trying to reinstall airtime using a symbolic link. I will post my result here...
  • http://dev.sourcefabric.org/browse/CC-2248

    New issue opened, Uninstall script fails in Debian Squeeze, i will try to debug a little bit Smile
  • Vote Up0Vote Down Paul BaranowskiPaul Baranowski
    Posts: 389Member, Administrator, Sourcefabric Team
    You need to type "sudo php airtime-uninstall.php" in order for it to work.


    Paul Baranowski
    CTO, Sourcefabric, http://sourcefabric.org

    +1 (416) 832-6436 (Cell)
    Skype: paulbaranowski
    720 Bathurst St. / Suite 203 / Toronto / ON / M5S 2R4 / Canada



    On Wed, May 4, 2011 at 5:46 PM, Andrea Giardini <
    airtime-support@lists.sourcefabric.org> wrote:

    > http://dev.sourcefabric.org/browse/CC-2248
    >
    > New issue opened, Uninstall script fails in Debian Squeeze, i will try to
    > debug a little bit [image: Smile]
    >

  • Hey Paul, he's running it under root in debian, so the missing "sudo" shouldnt be a problem.

    Andrea, did updating your storage location fix the problem?
    Airtime Pro Hosting: http://airtime.pro
  • That's not the problem...

    I launched "php airtime-uninstall.php" from root user and it doesn't work on Debian, i found some errors on directory retrieving inside the uninstall script. I think that i can solve the problem between tonight or maybe tomorrow (i must only test my changes).

    I repeat... "sudo" command doesn't exist in Debian, you can install it, but that's not the right way to solve the problem. In the uninstall script i found several calls to it.

    However no problem, i will publish my code in the bug tracker soon Wink

    @Martin
    I will try soon and i will let you know here Wink

    p.s. Sorry for my bad english! XD
  • Finally got it working Smile

    # Hostname
    base_url = 'localhost'
    base_port = 80
    


    I have airtime in a subdomain, so it doesn't work (asking for api to wordpress XD) I changed with my subdomain and now it works, streams and also "on air" button, the only thing that now doesn't work is meta-tag, it always display "Unknow". That's my log, it may help...

    @400000004dc3bb2a15f09d84 #########################################
    @400000004dc3bb2a15f0a554 #           *** pypo  ***               #
    @400000004dc3bb2a15f0a93c #     pypo notification gateway         #
    @400000004dc3bb2a15f0ad24 #########################################
    @400000004dc3bb2a15f0b10c 2011-05-06 11:10:56,367 DEBUG - [pypo-notify.py : notify_media_start_playing() : line 75] - #################################################
    @400000004dc3bb2a160398e4 2011-05-06 11:10:56,369 DEBUG - [pypo-notify.py : notify_media_start_playing() : line 76] - # Calling server to update about what's playing #
    @400000004dc3bb2a1625c6e4 2011-05-06 11:10:56,371 DEBUG - [pypo-notify.py : notify_media_start_playing() : line 77] - #################################################
    @400000004dc3bb2a162b50dc 2011-05-06 11:10:56,371 DEBUG - [pypo-notify.py : notify_media_start_playing() : line 78] - data = 2
    @400000004dc3bb2a163278e4 2011-05-06 11:10:56,372 DEBUG - [api_client.py : notify_media_item_start_playing() : line 274] - http://overadio.dyndns.org:80/api/notify-media-item-start-play/api_key/%%api_key%%/media_id/6/schedule_id/2
    @400000004dc3bb2b26e158a4 2011-05-06 11:10:57,651 INFO - [api_client.py : notify_media_item_start_playing() : line 278] - API-Status 1
    @400000004dc3bb2b26e7ec3c 2011-05-06 11:10:57,652 INFO - [api_client.py : notify_media_item_start_playing() : line 279] - API-Message 
    @400000004dc3bb2b26f077bc 2011-05-06 11:10:57,653 DEBUG - [pypo-notify.py : notify_media_start_playing() : line 80] - Response: {"status": 1, "message": ""}
    


    I will let you know about my progress Wink
  • I can't get meta-data stream... Any solution?

    Edit:
    Ok in mp3 stream, no way for ogg stream...
  • Ok, just readed wiki's pages Smile

    Problem solved!

    http://wiki.sourcefabric.org/display/CC/Airtime+1.8.x+FAQ

    However if someone needs to change his storage folder pay attention to have the right owner:group (root and www-data) and run a database update ( airtime-update-db-settings ) after editing /etc/airtime/airtime.conf

    p.s. are you shure that airtime-update-db-settings will update also the files directory? I think it's not running so good... Database file's locations remains the same!
  • Hey Andrea!

    Yes it is easy to enable metadata on OGG streams but be careful! You may find that your users are being disconnected at the end of every track:

    Listeners are disconnected at the end of every track
    http://savonet.sourceforge.net/doc-svn/faq.html

    Airtime Pro Hosting: http://airtime.pro
  • On air button not working - grey(not active)


    Linux debian 2.6.32-5-686 #1 SMP Tue Mar 8 21:36:00 UTC 2011 i686
    Airtime {"version":"1.8.1"}

    i have rebooted and checked that both timezone and host correspond, airtime is up i can login and create playlists and programs but "on-air" remains greyed out.

    log:
    ftp://109.233.212.17/NasheRadio/airtime_log.tar.gz

  • Vote Up0Vote Down Andrey PodshivalovAndrey Podshivalov
    Posts: 1,526Member, Administrator, Sourcefabric Team
    In your case the RabbitMQ is not working properly. Check it.
    I found in your pypo log:
    socket.error: [Errno 111] Connection refused

  • Hi Nickolas,

    For some reason on Debian systems, RabbitMQ needs to be started manually (even after reboot!). Please try
    service rabbitmq-server start
    as root.
    Airtime Pro Hosting: http://airtime.pro